WordPress.org

Ready to get started?Download WordPress

Forums

Fatal PHP Error - PicLens plugin (5 posts)

  1. crystak
    Member
    Posted 6 years ago #

    So I tried to enable the PicLens WP plugin when the error:

    "ERROR: WP Piclens REQUIRES PHP version 5.1 or greater, your WordPress Blog is using PHP 4.4.4."

    came up. My host has PHP 5 on their servers, infact PHP 5.2.3 and I don't understand why I am having this problem.

    Is this related to wordpress at all, or should I contact my host support, which is Hostgator by the way?

  2. thewritersmanifesto
    Member
    Posted 6 years ago #

    Did you install the plugin in the right directory? Sorry to ask but often we tend to overlook these things?

    Also, you want to make sure that it doesn't sit in a double folder e.g.
    public_html/wp-content/plugins/pic_lens/pic_lens

    It should only be the one folder of your Plugin. Also, some Plugins only need the actual .php file uploaded, not the folder especially if there is only a .php file within.

    Just de-activate the Plugin and you should be fine. If it doesn't work after trying again it might not be compatible depending on the version of WP you are using/

  3. crystak
    Member
    Posted 6 years ago #

    Yep, all is installed fine. I can see the plug in under the Plugins tab in wordpress and it's installed correctly.

    I'm running the latest version and I'm sure this pic_lens must be compatible as it's quite a well known plugin.

    I'm really confused. I've contacted my host support to see what they think.

  4. mUKABR
    Member
    Posted 5 years ago #

    Same problem here...

    "ERROR: WP Piclens REQUIRES PHP version 5.1 or greater, your WordPress Blog is using PHP 4.4.8."

    My host use: PHP version 5.2.5

    PicLens needs: PHP5+ (with libXML support)
    Waiting answer from host about this libXML support...

  5. mUKABR
    Member
    Posted 5 years ago #

    Problem solved...

    php 5 is not the default php version on some servers/hosts, so you need to enable php5 for your account by adding the following line to the .htaccess file

    AddHandler application/x-httpd-php5 .php .php4 .php5 .php3 .phtml

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.