WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal G2 error when new users register (7 posts)

  1. middlenameproductions
    Member
    Posted 6 years ago #

    I am currently running WordPress 2.51 with a Vslider3 theme and Gallery 2. You can view the site here

    Every time a new user tries to register they get this error:

    Fatal G2 error
    Here's the error from G2: Error (ERROR_MISSING_OBJECT)
    in modules/core/classes/helpers/GalleryUserHelper_medium.class at line 143 (GalleryCoreApi::error)
    in modules/core/classes/GalleryCoreApi.class at line 533 (GalleryUserHelper_medium::fetchUserByUserName)
    in /home/fhlinux150/f/fight-2-see.co.uk/user/htdocs/wordpress/wp-content/plugins/wpg2/wpg2embed.inc at line 199 (GalleryCoreApi::fetchUserByUserName)
    in ??? at line 0
    in /home/fhlinux150/f/fight-2-see.co.uk/user/htdocs/wordpress/wp-includes/plugin.php at line 311
    in /home/fhlinux150/f/fight-2-see.co.uk/user/htdocs/wordpress/wp-includes/registration.php at line 201
    in /home/fhlinux150/f/fight-2-see.co.uk/user/htdocs/wordpress/wp-includes/registration.php at line 279
    in /home/fhlinux150/f/fight-2-see.co.uk/user/htdocs/wordpress/wp-login.php at line 179
    in /home/fhlinux150/f/fight-2-see.co.uk/user/htdocs/wordpress/wp-login.php at line 304

    I tried replacing the individual files listed with no success.

    Anyhelp would be GREATLY apreciated.

  2. middlenameproductions
    Member
    Posted 6 years ago #

    Error was with G2. Their beta WPG2 pluggin fixes this issue.

  3. Anonymous
    Unregistered
    Posted 6 years ago #

    I am having this very same issue, and it's driving me mad.

    When a user registers, it throws the error right away, no confirmation email is sent to them, I even set wp to accept all registrations without confirmation, and still get the error.

    So when you say Beta version, do you mean I should grab one of the nightly builds and go from there? I am currently running Gallery2 version 2.2.5. I also looked at the link for the first guys post and he has not yet fixed his problem.

    I am running WP v2.5.1, if I install an earlier version of WP will it fix my problem? I have waaaaay too much time invested in this already.

  4. Anonymous
    Unregistered
    Posted 6 years ago #

    I installed an earlier version of wordpress to see if it would fix my problem (v 2.3.2-RC1)

    It creates another problem, when validating the wpg2 plugin I get this error: "WPG2 requires a minimum WordPress build of 7558 and has detected your WordPress build 6124 does not meet the minimum build requirement."

    so how does ANYONE in the world get this wpg2 plugin to work?

    Is there another, better photo plugin for WordPress?

  5. Anonymous
    Unregistered
    Posted 6 years ago #

    The solution is here: http://wordpress.org/extend/plugins/nextgen-gallery/

    WordPress + WGP2 + Gallery2 = crap

  6. Anonymous
    Unregistered
    Posted 6 years ago #

    FYI: I just updated to wordpress v2.6 and I still get the same error.

  7. middlenameproductions
    Member
    Posted 5 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic