WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Fatal errors after upgrade from 1.9.13 to 2.0 (13 posts)

  1. James
    Member
    Posted 1 year ago #

    Hi. Just tried to update to latest version from previous 1.9.13 and the auto update failed and took down the site (just error messages when trying to access site or admin area). So renamed then deleted plugin via FTP to deactivate it which bought admin area and site backup. Tried a fresh install instead, but still getting errors and plugin will not activate.

    The errors (displayed ina box at the top of the plugin page in WP admin) say:

    Warning: require_once(/home/abc/public_html/wp-content/plugins/nextgen-gallery/lib/core.php) [function.require-once]: failed to open stream: No such file or directory in /home/abc/public_html/wp-content/plugins/nextgen-gallery/nggallery.php on line 284

    Fatal error: require_once() [function.require]: Failed opening required '/home/abc/public_html/wp-content/plugins/nextgen-gallery/lib/core.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/abc/public_html/wp-content/plugins/nextgen-gallery/nggallery.php on line 284

    I have WP 3.5.2 and everything was working fine immediately prior to upgrade. Just about to roll back to previous version, fingers crossed!

    Any ideas what these error messages might point to?

    Thanks, James

    http://wordpress.org/plugins/nextgen-gallery/

  2. mweichert
    Member
    Posted 1 year ago #

    Hi James,

    nggallery.php of version 2.0.0 doesn't make any reference to lib/core.php - but 1.9.13 did.

    Did you download the 2.0.0 zip, unpack it locally, and then upload the files via FTP? If so, it looks like some of the files didn't get replaced properly.

    Please try re-uploading the files. If you want to be absolutely sure that you have the most up-to-date files, you could delete your nextgen-gallery folder (or rename it to nextgen-gallery.old) and re-upload all files.

    Let us know how you make out.

    Cheers,
    Mike

  3. tomdavis360
    Member
    Posted 1 year ago #

    Had the same problem. Did what you said above, twice. Still no galleries. Where can I get the old version. I have to get this site on line as the artist I built it for will not have another show. She is dying. No BS...just tell me where to get the 1.9.3 version so I can get her happy.

  4. Benjamin
    Member
    Posted 1 year ago #

  5. James
    Member
    Posted 1 year ago #

    Seems to have been a caching issue. I completely uninstalled the old version of the plugin, cleared all caches (disc, APC and Cloudflare) then did a fresh install of v2.0. This seems to have done the trick and no more errors!

    The only problem is that I have now lost all of my galleries: 0 images, 0 galleries,0 albums :'(

    Is there a quick way to restore the old galleries, or do I have to start from scratch again?

  6. tomdavis360
    Member
    Posted 1 year ago #

    Benjamin:

    Thank you for the very quick response. I have her gallery back on-line and she will likely never know. You helped keep an old lady happy.

    I believe what happened was that the auto-update utility did not work. I have other sites and will try your update and new version. The earlier version worked great and I believe in updates.

    I hope those that read about my issue above will also read this and that you stepped up immediately to help me move back to the older version. I will not forget it.

  7. James
    Member
    Posted 1 year ago #

    Any thoughts on restoring galleries and albums that disappeared after the upgrade anyone please???

  8. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    James - unfortunately, it sounds like you probably lost the images. It wasn't the upgrade, it was the way you did the rollback. "Uninstalling" - that is, clicking "Uninstall" from the plugin list - removes all files/data associated with the plugin.

    That's true for all plugins and all versions of NG. Rather than run the uninstall process, the way to roll back or change versions or update is just to refresh the files:

    http://www.nextgen-gallery.com/how-to-rollback-a-version/

    Sadly, I recognize that won't really help you much at this point. Painful to say.

    Erick

  9. James
    Member
    Posted 1 year ago #

    Given up. Upgrading broke another site (fatal errors and then lost galleries) despite me following all the instructions above and elsewhere and definitely not unistalling the plugin (deactivating and replacing files by FTP only). I did try the auto update again first - this failed with fatal errors and I think is what caused all my galleries and images to disappear.

    Sadly the plugin is too much hassle for what it is worth for me, so I have now uninstalled it completely from all my sites :'(

    Be warned - don't upgrade yet!!!!

  10. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    If anyone is having this particular issue, we thing it's related to APC / opcode cache. Please try installing and activating http://wordpress.org/plugins/wp-apc-panel/ and try clicking the button to "Clear opcode cache". If you do this, please let us know if it resolves the issue for you. Thanks.

  11. James
    Member
    Posted 1 year ago #

    Interesting suggestion. The first website I tried to upgrade to the new plugin version did NOT have APC caching installed, so I don't think that was the problem there. The second website I tried (the one where I did everything exactly as instructed) did have APC caching installed and running via the W3TC plugin. I cleared all of the caches several times during the upgrade. So not sure if this would have helped.

    W3TC has a clear cache function anyway so there is no need to install the additional plugin. Also why not just navigate to apc.php if you have APC caching installed, rather than installing another plugin just so you can do this from the WP admin area?

    Hope you manage to get if fixed anyway, good luck!

  12. Thrills 2 Chills Travel
    Member
    Posted 1 year ago #

    I have also upgraded to the latest version but when I try to upload images to a new gallery, I end up getting an http: error and no images uploaded. This is very frustrating! I need a response asap, please.

    Thank you.

  13. Anduril
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.