WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error with PHPBB integration - wp-united (4 posts)

  1. talksina
    Member
    Posted 7 years ago #

    Hi, I have integrated my wordpress into a phpbb. and, now, I am trying to integrate the previously registered wp users into phpbb user table
    when I press the Begin button, it regularly goes to Process, from Process, Perform actions (telling it to create phpbb user from wp user) and pressing Perform action, it gives me this error
    Fatal error: Cannot redeclare username_exists() (previously declared in /var/www/audiomontaggi.net/phpbb/wp-united/wp-functions.php:120) in /var/www/audiomontaggi.net/phpbb/wp-united/wp-functions.php
    on line 120
    someone has any idea? thanks

  2. whooami
    Member
    Posted 7 years ago #

    Fatal error: Cannot redeclare username_exists() (previously declared in /var/www/audiomontaggi.net/phpbb/wp-united/wp-functions.php:120) in /var/www/audiomontaggi.net/phpbb/wp-united/wp-functions.php
    on line 120

    This is telling you that the function, username_exists(), is being defined more than once.

    WordPress uses that function, and defines it. phpBB sees that function, and defines it.

    PHP doesnt allow that. It wants one function, period.

  3. talksina
    Member
    Posted 7 years ago #

    i know it!
    I just modified the string from require to require_once, when the program called wp-functions.php and got the same error, on another file, wpu-widgets, I think was the name.
    and declaring require_once also to that, I got another error
    Fatal error: Cannot redeclare wp_unregister_globals() (previously declared in /var/www/audiomontaggi.net/phpbb/admin/wpu_usermap.php(549) : eval()'d code:23)
    in /var/www/audiomontaggi.net/phpbb/admin/wpu_usermap.php(549) : eval()'d code on line 22
    on my php running on the server(i have no root access) globals are off, don't know what's going on there, if that is the reason

  4. bacu
    Member
    Posted 7 years ago #

    Hallo,
    also to it appen with wpress intergrated with phpbb using wp-united.
    I've notice that the problem occorred after I've installed and activated the Dean's FCKEditor For WordPressplug-in.
    If I deactivate it, all works good.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.