WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error when uploading images (9 posts)

  1. andreacimatti
    Member
    Posted 6 years ago #

    Hello,
    I have recently upgraded to 2.3 from 2.2. I am getting a strange error for which I have not found anything of help online:

    "Fatal error: Cannot use object of type WP_Error as array in /home/public_html/wp/wp-includes/taxonomy.php on line 1010"

    I have tried removing several plugins, reinstalling... nothing
    Any ideas where to start resolving this problem?

  2. moshu
    Member
    Posted 6 years ago #

    This is the only reference to that error in the forum:
    http://wordpress.org/support/topic/135958?replies=2

  3. fvstudio
    Member
    Posted 6 years ago #

    I too have this error
    solutions??????????

  4. fvstudio
    Member
    Posted 6 years ago #

    Not using any plug ins all deactivated

  5. andreacimatti
    Member
    Posted 6 years ago #

    ok..I fixed the problem. The problem was that I switched server so the image paths were not being read correctly.
    To get it to work again I erased everyting and did the following:
    1. I did a fresh install of wordpress and made sure that the image upload worked without errors on my first post.
    2. I ran an automatic subtituion of the previous server path with the new correct server path in my sql file.
    3. I imported the sql file with the substitutions.
    everyhing works fine.

  6. danatstadiumvolleyball
    Member
    Posted 6 years ago #

    I didn't switch server, but also am getting this error.

    Is there any other support than erasing everything and doing a fresh install?

  7. duplemeter
    Member
    Posted 6 years ago #

    I get this also - for image uploads & page & post saves. After a fresh install & new DB, I now only get it when trying to upload images.

    This seems to be a *huge* issue with only a hit or miss solution.

  8. danatstadiumvolleyball
    Member
    Posted 6 years ago #

    A huge issue is this forum that is very difficult to search and keep messages as a thread... there are now about 5 separate posts regarding this issue

    "Fatal error: Cannot use object of type WP_Error as array in /home/public_html/wp/wp-includes/taxonomy.php on line 1010"

    and no answers yet.... this post should not have been marked resolved - and it is probably being overlooked by the smart ones who can help;)

  9. andreacimatti
    Member
    Posted 6 years ago #

    sorry, you are right. for me this is resolved

Topic Closed

This topic has been closed to new replies.

About this Topic