WordPress.org

Ready to get started?Download WordPress

Forums

Acunetix Secure WordPress
[resolved] Fatal Error when Update (30 posts)

  1. blogsaays
    Member
    Posted 2 years ago #

    I am getting following Fatal error after updating

    Plugin could not be activated because it triggered a fatal error.

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /home/public_html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    Fatal error: require_once() [function.require]: Failed opening required 'inc/json.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

  2. Daniel
    Member
    Posted 2 years ago #

    Hi,

    I've the same problem..

  3. perakfood
    Member
    Posted 2 years ago #

    My problem is like below:-
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/perakfoo/public_html/wp-admin/includes/file.php on line 924

  4. mal2809
    Member
    Posted 2 years ago #

    I just updated and got the same error as blogsaays. I couldn't get back into my admin and had to delete the files from the plugin area using ftp.

    My php version is 5.3.6.

    I use the Suffusion theme.

  5. GodlessKinser
    Member
    Posted 2 years ago #

    Same problem here. I got this one, too:

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /home/.../public_html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    Fatal error: require_once() [function.require]: Failed opening required 'inc/json.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/.../public_html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

  6. beyercenter
    Member
    Posted 2 years ago #

    i got no error. only apache 500 internal server error and blank page...
    not realy good...

  7. pixelnated
    Member
    Posted 2 years ago #

    the inc folder is missing so all require references will break it.

    what I did temp fix to get my site back up
    I commented out all the require references
    eg : require_once 'inc/json.php'

    all of them (the inc/ folder was not included in the package)
    also comment out this line
    $swwsd = new swWSD();

    once the site was back up, disabled the plugin until it gets updated.

    hope this helps

  8. pixelnated
    Member
    Posted 2 years ago #

    sorry, I should mention the file I was editing is secure-wordpress.php

  9. beyercenter
    Member
    Posted 2 years ago #

    all folders are missing. i have
    /css
    /img/
    /inc
    /js
    /language

    Uploaded old version and page is running fine :-)

  10. akarra
    Member
    Posted 2 years ago #

    Same deal as mal2809. Secure WordPress has been a great plug-in for me before. Would love to see this issue resolved.

  11. GodlessKinser
    Member
    Posted 2 years ago #

    I just went through my cPanel to delete the folder for that plug-in. I'll just wait for a fix before I re-install it.

  12. bigreddog
    Member
    Posted 2 years ago #

    Deleting the secure-wordpress directory fixed things for now. Had a heart attack there for a second..

  13. Jon W
    Member
    Posted 2 years ago #

    I had same problem today. Also problems with related posts plugins, several failed, got one working.

    Is there a temporary alternative for Secure WordPress?

  14. beyercenter
    Member
    Posted 2 years ago #

    use 2.0.1 of this plugin!

  15. Jon W
    Member
    Posted 2 years ago #

    is there somewhere to download that? Guess I may have a copy somewhere .....

  16. beyercenter
    Member
    Posted 2 years ago #

  17. Jon W
    Member
    Posted 2 years ago #

    Well I never! Did not know all versions were stored. Cool.

  18. gzejer
    Member
    Posted 2 years ago #

    Well, it appears that I have the same problem but I tried deleting and uploading the previous version and it is still giving me the same message. I think it may have something to do with the fatal error related to some google plugin associated but i am not sure. Any ideas?

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /home/globalp/public_html/blog/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    Fatal error: require_once() [function.require]: Failed opening required 'inc/json.php' (include_path='/home/globalp/public_html/blog/wp-content/plugins/official-google-site-verification-plugin/external/php-client::.:/usr/lib/php:/usr/local/lib/php') in /home/globalp/public_html/blog/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

  19. paulzag
    Member
    Posted 2 years ago #

    @gzejer your problem is with secure-wordpress.

    Delete the directory /home/globalp/public_html/blog/wp-content/plugins/secure-wordpress/

    download install 2.0.1 manually (not via add plugin) get it from http://downloads.wordpress.org/plugin/secure-wordpress.2.0.1.zip

    Wait for version 2.0.3 to be released. I'm guessing it should take no longer than 24 hours

  20. rollerband
    Member
    Posted 2 years ago #

    I have resumed to the older version. 2.0.1. And everything is back to normal. HOwever, is still prompt for the upgrade on Secure WordPress plugin. I simply ignore it till further notice from the source.
    Below is steps on how I resolved it:-

    1) Download the plugin to your desktop (Link given by beyercenter)
    2) http://wordpress.org/extend/plugins/secure-wordpress/download/
    3) Login to your cPanel> File Manager, and direct to /public_html/wp-content/plugins/secure-wordpress
    4) Upload the Zipped folder from your desktop to the directory of #3) above.
    5) Unzip it into the same folder, and open it (/public_html/wp-content/plugins/secure-wordpres/secure-wordpres)
    6) Now, you have 2 similar folders for secure-wordpres.
    7) Move all the files from the Unzipped folders and overwrite to the upper leveled directory. i.e /public_html/wp-content/plugins/secure-wordpress
    8) It should work. If all is done, remember to delete/clean up the unnecessary Zipped file.

  21. WebsiteDefender
    Member
    Posted 2 years ago #

    Hi,

    First of all we are really sorry for the inconvenience caused with this plugin update.

    We already uploaded a fixed version of the plugin which can be downloaded from: http://downloads.wordpress.org/plugin/secure-wordpress.2.0.3.zip.

    If you have problems accessing your blog because of the plugin update, simply login via FTP or your host's control panel and delete the plugin directory. The default plugin directory can be found in /wp-content/plugins/ WordPress sub directory.

    While hoping you find this plugin useful, feel free to post any queries or suggestions you might have on the WebsiteDefender forums; http://www.websitedefender.com/forums.

    Looking forward to hearing from you.

    Regards,
    Robert Abela
    Technical Manager - WebsiteDefender

  22. majmar21
    Member
    Posted 2 years ago #

    Hello,
    I've deleted the secure wordpress folder from my plugins directory and I still get the same message. I downloaded the new secure wordpress zip file and uploaded it to my server. I unzipped and put the secure wordpress folder back in my plugins directory where it was before, BUT I'm still getting the same message.

    Failed opening required 'inc/json.php' (include_path='.:/usr/lib/php:/usr/local/lib/php')

    What am I doing wrong? Do I need to refresh something? Is there something else I need to do?

    Help!

  23. gzejer
    Member
    Posted 2 years ago #

    I deleted the secure-wordpress directory and I still have the same issue. Any other ideas? This plugin has something to do with the secure-wordpress and official-google-site-verification-plugin working together but I am not sure how.

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /home/globalp/public_html/blog/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    Fatal error: require_once() [function.require]: Failed opening required 'inc/json.php' (include_path='/home/globalp/public_html/blog/wp-content/plugins/official-google-site-verification-plugin/external/php-client::.:/usr/lib/php:/usr/local/lib/php') in /home/globalp/public_html/blog/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

  24. paulzag
    Member
    Posted 2 years ago #

    @majmar21 and @gzejer Always do things one step at a time especially when under stress during a failure.

    1. Delete the secure-wordpress directory in your wp-content/plugins/ directory. If you want you could rename instead of delete the directory to broken-secure-wordpress.
    2. Check your site is working without the plugin
    3. If your site still has errors find the other plugin that is causing problems and delete/rename its directory
    4. repeat step 3 until your site is working - this could involve removing/renaming every plugin in the directory.
    5. Manually upload the known working 2.0.1 or 2.0.3 version to your site. Automatic update didn't have the new version 12 hours ago.
    6. Activate the known working version.
    7. Check your site is working.
    8. If your site is broken go back to steps 1, 2, 3 and 4 and leave it there
  25. majmar21
    Member
    Posted 2 years ago #

    I've renamed all my plugins and uploaded the 2.0.1 version of secure wordpress plugin. I'm still getting the same error. I don't understand what the problem is. Does anybody have any ideas on this?

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    Fatal error: require_once() [function.require]: Failed opening required 'inc/json.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

  26. vdilorenzo
    Member
    Posted 2 years ago #

    Hi:

    I received this fatal error when updating the donation plug in. I can't get into my wordpress at all. Can anyone please help? I run Colorway Theme. Thank you.

    Warning: require(/home/valeried/public_html/wp-content/plugins/wp-paypal-simple-donation-widget/classes/settings.php) [function.require]: failed to open stream: No such file or directory in /home/valeried/public_html/wp-content/plugins/wp-paypal-simple-donation-widget/paypal-payments.php on line 572

    Fatal error: require() [function.require]: Failed opening required '/home/valeried/public_html/wp-content/plugins/wp-paypal-simple-donation-widget/classes/settings.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/valeried/public_html/wp-content/plugins/wp-paypal-simple-donation-widget/paypal-payments.php on line 572

  27. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    FTP into your site (or use whatever file management application your host provides) & delete the wp-content/plugins/wp-paypal-simple-donation-widget folder.

  28. vdilorenzo
    Member
    Posted 2 years ago #

    Thanks for your help Esmi...I am so new to this and do not know code so I must ask clarification. When you say FTP into your site - what does that mean? Do I contact the host provider? (which is Hostgator). Because I can't get into the site at all now; when I log in, I just get the error message.

    Thanks again - Valerie

  29. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Please see the link I provided in my previous post.

  30. vdilorenzo
    Member
    Posted 2 years ago #

    It worked!

    This newbie sincerely appreciates your help, time and patience.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic