WordPress.org

Ready to get started?Download WordPress

Forums

Visual Form Builder
[resolved] Fatal error when trying to view entries (7 posts)

  1. sammcc
    Member
    Posted 1 year ago #

    I'm getting this error when I try to view Entries (form submissions - there is one so far)
    Fatal error: Call to a member function prepare_items() on a non-object in /home/north4g5/public_html/wp-content/plugins/visual-form-builder/visual-form-builder.php on line 1767
    I tried deactivating all plugins, I'm running WP version 3.5.1

    http://wordpress.org/extend/plugins/visual-form-builder/

  2. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    The only reason you'd be getting this error is if the Entries class isn't loaded, which means that the file isn't included for you for some reason.

    Make sure you have an updated copy of the plugin and that your wp-content folder permissions are set to either 750 or 755.

  3. sammcc
    Member
    Posted 1 year ago #

    I checked and the wp-content perms are set to 755, I purchased the pro version and installed it and am now getting the following error when I try to access entries:

    Fatal error: Call to a member function entries_errors() on a non-object in /home/north4g5/public_html/wp-content/plugins/visual-form-builder-pro/visual-form-builder-pro.php on line 3621

    I am able to download the entries via csv.

    Any ideas?

  4. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    What's your server setup?

  5. sammcc
    Member
    Posted 1 year ago #

    PHP Version 5.2.17
    MySQL 5.1.59
    Apache 2.2.23
    WP version 3.5.1

    I tried it on two other installations, one on a different server worked and one on the same server gave this error when I tried to save the form:

    Warning: trim() expects parameter 1 to be string, array given in /home/angela/public_html/wp-includes/option.php on line 35

    Warning: unlink(/home/angela/public_html/wp-content/themes/Atlas/data/) [function.unlink]: Is a directory in /home/angela/public_html/wp-content/themes/Atlas/functions.php on line 28
    1

  6. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Okay, if it works on a different server it's clear there's a configuration setting somewhere causing the issue. I suggest contacting them and letting them know you are having issues.

    The second error points to a theme issue, so you might try changing themes to confirm.

  7. Amos Lee
    Member
    Posted 1 year ago #

    I had also meet the problem , I translated the po file to chinese,when I transelate the""Visual Form Builder Pro"string to chinese word "表单",the issue occuerd.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic