WordPress.org

Ready to get started?Download WordPress

Forums

BP Group Hierarchy
[resolved] Fatal Error when setting up groups on step 2 (14 posts)

  1. crazywpgeek
    Member
    Posted 12 months ago #

    Ok I'm getting a fatal error on step 2. This is what it says.

    Fatal error: Using $this when not in object context in /home3/shonuff/public_html/networking/wp-content/plugins/bp-group-hierarchy/extension.php on line 122

    Here is screencast video: http://screencast.com/t/SS0Zpdv72v

    Can you tell me if there is a workaround for this?

    http://wordpress.org/extend/plugins/bp-group-hierarchy/

  2. crazywpgeek
    Member
    Posted 11 months ago #

    Hey I'm still having problems with this. Is there any support for this at all?

    Getting this error when creating a group on step 2 which is where this plugin is supposed to work.

    Fatal error: Using $this when not in object context in /home3/shonuff/public_html/networking/wp-content/plugins/bp-group-hierarchy/extension.php on line 122

    Using WP 3.5.2 and BuddyPress latest 1.7

  3. David Dean
    Member
    Plugin Author

    Posted 11 months ago #

    Hi crazywpgeek -

    Can you provide some details on your install, including other active plugins, and your BP setup? This is the first report of a problem like yours.

    - David

  4. crazywpgeek
    Member
    Posted 11 months ago #

    Hi David,

    Did you watch the video I posted above? Here is the link again: http://screencast.com/t/SS0Zpdv72v

    As you can see with the video I'm using BuddyPress 1.8 and only your plugin (near the end after I disabled everything else).

    Groups are activated with BuddyPress

    I'm using buddyboss theme (and actually doesn't matter which theme because I tried the default theme for buddypress and its doing the same thing).

    wordpress 3.5.2

  5. grima
    Member
    Posted 11 months ago #

    Hi,

    I'm having same issue since update to BP 1.8.

    Since 1.8 rewrite the Group Extension API it was no surprise (nearly all plugins using groups broke) :
    http://codex.buddypress.org/developer/plugin-development/group-extension-api/

    As it was suggested on BP forums i switched back BP group files to 1.7 and everything goes back to normal for now.

    Thanks for your support and great extension !

  6. grima
    Member
    Posted 11 months ago #

    After a closer look my guess is the BP_Group_Extension is not anymore instanciated when calling screen function (at less).

    So only static access is usable, $this is not available.

  7. crazywpgeek
    Member
    Posted 11 months ago #

    @Grima,

    Thank you for this. I'm wondering if David will issue an update for this. Is it possible to roll back to BP 1.7 ?

    Thanks

    Kevin

  8. grima
    Member
    Posted 11 months ago #

    Don't know for a full rollback.

    I've just uploaded the 1.7 groups files overs 1.8 BP install, wich is dirty but do the trick waiting for patch.

    I followed this topic for the bbpress wich has quite the same problem i guess :
    http://bbpress.org/forums/topic/fatal-error-unable-to-create-forum-from-buddypress-group/

  9. David Dean
    Member
    Plugin Author

    Posted 11 months ago #

    Hi everybody -

    I am looking into this, but I am able to create groups without error on WP 3.5.2, BuddyPress 1.8 and Hierarchy 1.3.9. Step 2 presents no problems for me. If anyone can provide more specific details about what happens, that would speed up a resolution. For instance, do you have WP_DEBUG enabled? Are these new installs or upgrades?

    @crazywpgeek - your video (the whole site, really) does not load for me, so I haven't been able to watch it. Can you provide any more details about specific circumstances?

    - David

  10. crazywpgeek
    Member
    Posted 11 months ago #

    Hi David,

    Sorry about the video not loading as that is where 99% of all the info about this error is. I put the .mp4 video in a zip file. Are you able to open zip files?

    You can download it from here: http://www.firstpagecoach.com/error.zip
    **I'm uploading it now so it will take a few minutes for it to completely upload. file should be just over 15mb total**

    the url to the site is flyppl.com/networking

    I'll remove the password protection on it so you can see the site.

    In the wp-config.php debug mode is set to false.

    Using WordPress 3.5.2
    BuddyPress 1.8
    Hierachy 1.3.9

    I'll go ahead and activate only the buddypress and the hierachy plugins.

    As far as the installation: The site is a month old, and this error is after first installing the plugin and trying to setup groups.

    Let me know if the video plays. In the video I go through some troubleshooting (one of things I did I accidentally deactivated buddypress but figured it out later), but still doesn't work.

    Kevin

  11. grima
    Member
    Posted 11 months ago #

    I've just tried with BP 1.8.1 wich fix the problem.

    Here is the bug report matching :
    https://buddypress.trac.wordpress.org/ticket/5126

    Sorry for the report, it was a BP bug in the end.

  12. crazywpgeek
    Member
    Posted 11 months ago #

    Hi Grima,

    Thanks for posting this. So glad it got fixed. I will update to BP 1.8.1 and see what happens.

    Thanks

    Kevin

  13. David Dean
    Member
    Plugin Author

    Posted 11 months ago #

    Just came in to see whether this was ultimately caused by bug 5126. Looks like I'll need to add different PHP versions to the test rig along with all the different WP versions. :)

    Thanks, everyone!

  14. crazywpgeek
    Member
    Posted 11 months ago #

    David,

    Appreciate the work you do. Just donated $10 to this plugin for your hard work. I know its not much, but hopefully this will help a little.

    Thanks

    Kevin

Reply

You must log in to post.

About this Plugin

About this Topic