WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error when clicking on "Theme Options" (7 posts)

  1. arontcb
    Member
    Posted 1 year ago #

    When I click on "Theme Options" I get the following error:

    Fatal error: Call to undefined function wp_get_theme() in /homepages/43/d435850078/htdocs/app435850090/wp-content/themes/zeebusiness/includes/admin/theme-admin.php on line 11.

    Also it's telling me I should update to version 3.4.2 but when I click "Update Automatically" the following happens:

    Downloading update from http://wordpress.org/wordpress-3.4.2.zip…

    Unpacking the update…

    Warning: copy(/homepages/43/d435850078/htdocs/app435850090/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /homepages/43/d435850078/htdocs/app435850090/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Could not copy files.

    Installation Failed

    Please help

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Try upgrading WordPress manually. And please don't post the same question in multiple new topics.

  3. arontcb
    Member
    Posted 1 year ago #

    What about the problem with my theme options? And I JUSt opened an account and immediately needed to upgrade, why would they give me annoys version when I sign upon only to have me go through all of this to upgrade? I heard WordPress was complicated but my experience so far has been ridiculous.

  4. arontcb
    Member
    Posted 1 year ago #

    Sorry, "an old" not "annoys"

  5. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    why would they give me annoys version when I sign upon only to have me go through all of this to upgrade

    I have no idea. Try asking your hosts.

  6. arontcb
    Member
    Posted 1 year ago #

    Can you answer my question about why I'm getting an error when I click on "theme options"?

  7. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Sounds like a problem in your theme. Try re-uploading a fresh copy using FTP.

Topic Closed

This topic has been closed to new replies.

About this Topic