WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error when attempting to upgrade to 3.5 from 3.4.2 (5 posts)

  1. zonknz
    Member
    Posted 1 year ago #

    I'm getting the following error when trying to upgrade from 3.4.2 via ftp.

    Update WordPress

    Downloading update from http://wordpress.org/wordpress-3.5-new-bundled.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Warning: require_once(/var/www/wordpress/wp-content/upgrade/version-current.php) [function.require-once]: failed to open stream: Permission denied in /var/www/wordpress/wp-admin/includes/update-core.php on line 640

    Fatal error: require_once() [function.require]: Failed opening required '/var/www/wordpress/wp-content/upgrade/version-current.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/wordpress/wp-admin/includes/update-core.php on line 640

    This is not the first time i've tried to upgrade - this blog has been upgraded many, many times.

  2. zonknz
    Member
    Posted 1 year ago #

    The suggestion is a file permissions issue, but even setting (/var/www/wordpress/wp-content/upgrade/version-current.php) as 777 doesn't help...

    I have disabled all plugins, no change.

  3. zonknz
    Member
    Posted 1 year ago #

    i was afraid that might be the answer :/ will have to try this in test...

  4. zonknz
    Member
    Posted 1 year ago #

    ok - the file permissions on the folder

    /var/www/wordpress/wp-content/upgrade

    Were completed screwed up for some reason. I completed removed the upgrade folder and then upgraded without error.

    Deleting the upgrade folder is safe to do so.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.