WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] fatal error when activate new theme (7 posts)

  1. burselfwoman
    Member
    Posted 3 years ago #

    I installed new theme, but when I activated it, my website'gone, & appear this message: Fatal error: Call to undefined function register_nav_menus() in /home/sloki/user/k8026936/sites/burselfwoman.com/www/wp-content/themes/platform/sections/nav/section.nav.php on line 36
    Please, HELP! I'm dumb, don't know anything about all this stuffs. Help me with step by step. Many thanks.

  2. James
    Happiness Engineer
    Posted 3 years ago #

    You'll need to access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the Default theme (WordPress 1.5 - 2.9.2) or the Twenty Ten theme (WordPress 3.0 and higher) to activate and you should be able to access your Dashboard again.

  3. burselfwoman
    Member
    Posted 3 years ago #

    Hi James,
    Problem is solved. Thanks so much for your help.

  4. iamidiot
    Member
    Posted 3 years ago #

    Hey there, I'm having a similar problem and have tried the solution with no luck. I'm getting this error message whenever I go to my site's wp-admin. Any advice?

    Warning: Cannot modify header information - headers already sent by (output started at /home2/iamidiot/public_html/wp-content/plugins/ungallery/configuration_menu.php:302) in /home2/iamidiot/public_html/wp-includes/pluggable.php on line 890

  5. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    @iamidiot did you just install/activate new plugin? if so this could mean that your plugin isn't compatible with your WordPress version.

  6. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    Problem resolved for the original poster @iamidiot please open new topic.

  7. James
    Happiness Engineer
    Posted 3 years ago #

    burselfwoman, you're welcome!

    iamidiot, you have unexpected whitespace (either a space or an entire line) on line 302 of the /wp-content/plugins/ungallery/configuration_menu.php file. See this guide for more info.

    Alternatively, replacing the file with one from a fresh download may resolve the issue.

    If that doesn't help, please start your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags