WordPress.org

Ready to get started?Download WordPress

Forums

Bulk Watermark
[resolved] Fatal Error - Upload Directory (14 posts)

  1. orionis23
    Member
    Posted 1 year ago #

    I'm re-posting this issue from a previous thread since it has not been actually resolved publicly on these forums.

    The plugin is not working for me, I get the following error message. A post here on the WordPress forum on how this issue is resolved would be beneficial! Thanks!

    Using WP 3.4.2 and Bulk Watermark plugin version 1.5.1

    Fatal error: Uncaught exception 'UnexpectedValueException' with message 'RecursiveDirectoryIterator::__construct(/kunden/homepages/14/d424857031/htdocs/my_sites/tspb/homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/uploads) [recursivedirectoryiterator.--construct]: failed to open dir: No such file or directory' in /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/plugin-admin.php:268 Stack trace: #0 /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/plugin-admin.php(268): RecursiveDirectoryIterator->__construct('/kunden/homepag...') #1 /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/plugin-admin.php(770): Bulk_Watermark_Admin->listFiles('/kunden/homepag...') #2 [internal function]: Bulk_Watermark_Admin->optionsPage('') #3 /homepages/14/d424857031/htdocs/my_sites/tspb/wp-includes/plugin.php(403): call_user_func_array(Array, Array) #4 /homepages/14/d424857031/htdocs/my_sites/ in /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/plugin-admin.php on line 268

    http://wordpress.org/extend/plugins/bulk-watermark/

  2. ChrisHurst
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried upgrading to the latest version?
    We recently released a new version that should resolve your issue.

    Thank You!

  3. orionis23
    Member
    Posted 1 year ago #

    Updated to the newest version and got as far as the watermark preview, which is a broken image so I wasn't comfortable advancing to the bulk application.

    The "Plugin Diagnostics Check" meta box shows:

    PHP allow_url_fopen: is disabled!
    Enable allow_url_fopen in php.ini!

    Yet allow_url_fopen is indeed enabled via a php.ini file as is confirmed via a phpinfo file which shows under PHP Core:

    Directive: allow_url_fopen
    Local Value: On
    Master Valure: On

  4. ChrisHurst
    Member
    Plugin Author

    Posted 1 year ago #

    Most likely you should consult with your web hosting provider, they can usually help with configuring the PHP.ini for you.

    Many hosts allow for PHP.ini to be configured on a per directory basis, which means your "confirmation" may not be 100% accurate.

    Another suggestion might be to contact us directly and provide a link to a screenshot of the plugin settings page. http://mywebsiteadvisor.com/support/

    Thank You!

  5. orionis23
    Member
    Posted 1 year ago #

    Hosting company will tell me to contact the plug-in developer as this is a PHP5 vs. the plugin issue seeing as how the directory I am enabling allow_url_fopen in has successfully done so.

    PHP5 has allow_url_fopen off by default, and php.ini in my site's root folder is successfully activating it, but this is not a recursive action... if the plugin requires a PHP5 installation with allow_url_fopen activated in a specific directory, then this should be part of the plugin documentation but I'm not seeing anything in the F.A.Q.

    Contacting you directly will defeat the purpose of these support forums! ;-)

    Here are the contents of the "Plugin Diagnostics Check" meta box:

    Plugin Version: 1.6.0

    Server OS: Linux (32 bit)

    Required PHP Version: 5.0+
    Current PHP Version: 5.2.17

    GD Support Enabled!
    FreeType Support Enabled!

    PHP Safe Mode: is disabled!

    PHP allow_url_fopen: is disabled!
    Enable allow_url_fopen in php.ini!

    Disabled PHP Functions: None Found!

    Memory Use: 24.8 / 256M

    Peak Memory Use: 24.9 / 256M

    Server Load Average: 7.54, 6.86, 6.34

  6. ChrisHurst
    Member
    Plugin Author

    Posted 1 year ago #

    We are very sorry for any confusion.
    It sounds like you understand what is going on, but to clarify:
    You need to enable the 'allow_url_fopen' with php.ini and when you have done this correctly the plugin will not havethe error message anymore.

    Thank You!

  7. orionis23
    Member
    Posted 1 year ago #

    I appreciate the attempts to help, but the confusion seems to be in the assumption that to simply "enable the 'allow_url_fopen' with php.ini" will solve the problem, because in my case thus far it is not doing so.

    I have enabled allow_url_fopen on the site's root directory, and in several other directories for good measure, including the uploads directory... below are links to phpinfo pages in each of the directories where you can see confirmation that the function is successfully enabled, yet the plugin in still does not recognize this and is not working.

    http://www.truccosemipermanentebologna.com/phpinfo.php

    http://www.truccosemipermanentebologna.com/wp-content/phpinfo.php

    http://www.truccosemipermanentebologna.com/wp-content/uploads/phpinfo.php

    http://www.truccosemipermanentebologna.com/wp-content/plugins/bulk-watermark/phpinfo.php

    P.S. To mark this thread as resolved, either:

    1) the plugin must be working for me, or
    2) we come to the conclusion that the plugin will only work in some instances (not all)

    I appreciate your understanding and help! :-)

  8. ChrisHurst
    Member
    Plugin Author

    Posted 1 year ago #

    Once again we would recommend that you contact your web hosting provider to ask about that setting. From everything you say, it sounds like it should work. We have never had as much difficulty as you describe, and are currently unsure of exactly what the trouble could be for you.

  9. orionis23
    Member
    Posted 1 year ago #

    Clients hosting provider confirmed that allow_url_fopen is enabled in the directories in question and suggested we contact the plugin developers (as expected... it's not my first day at work!) They also suggest we confirm in which directories it should be enabled (again, since enabling it is not recursive). So, in which directory is the plugin checking for allow_url_fopen when creating the output of the "Plugin Diagnostics Check" meta-box?

  10. ChrisHurst
    Member
    Plugin Author

    Posted 1 year ago #

    Could you try putting the php.ini in the wp-admin directory? maybe even put a phpinfo file there as well.

    Thank You!

  11. orionis23
    Member
    Posted 1 year ago #

    Enabling allow_url_fopen in the wp-admin directory has successfully allowed the Plugin Diagnostics Check to pass, as well as allowing a successful Watermark Preview image to be created!

    Unfortunately, advancing to the Apply Bulk Watermark phase and selecting a directory from within the uploads directory has resulted in the original error (using version 1.6.1):

    Fatal error: Uncaught exception 'UnexpectedValueException' with message 'RecursiveDirectoryIterator::__construct(/kunden/homepages/14/d424857031/htdocs/my_sites/tspb/homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/uploads/2012/08) [recursivedirectoryiterator.--construct]: failed to open dir: No such file or directory' in /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/bulk-watermark-tools.php:430 Stack trace: #0 /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/bulk-watermark-tools.php(430): RecursiveDirectoryIterator->__construct('/kunden/homepag...') #1 /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/bulk-watermark-plugin.php(792): Bulk_Watermark_Tools->list_files('/kunden/homepag...') #2 [internal function]: Bulk_Watermark_Plugin->bulk_watermark_manager(Array) #3 /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/bulk-watermark-settings-p in /homepages/14/d424857031/htdocs/my_sites/tspb/wp-content/plugins/bulk-watermark/bulk-watermark-tools.php on line 430

  12. ChrisHurst
    Member
    Plugin Author

    Posted 1 year ago #

    We believe that we have resolved that issue with the recent update, would you please update the plugin and let us know how it works for you.

    Thank you!

  13. orionis23
    Member
    Posted 1 year ago #

    Success!! The Apply Bulk Watermark phase now correctly follows the uploads directory path and applies the watermark to images selected. Unfortunately it is not recognizing all images in the directory, specifically those with the extension .jpeg as opposed to .jpg (and this is almost half of all the images!)

    This should be an fix in the allowed file types, I'll move it to a new thread though so that this one can remain resolved as it indeed is!

  14. ChrisHurst
    Member
    Plugin Author

    Posted 1 year ago #

    We have updated the plugin to include images with a .jpeg extension.
    Please update to the latest version when it becomes available.

    Thank You!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.