WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error. the update?? (17 posts)

  1. shevchur
    Member
    Posted 1 year ago #

    Fatal error: Class 'WC_API' not found in /home/goodstoc/goodstock.com.ua/i/wp-content/plugins/woocommerce/woocommerce.php on line 142

    update WP to 2.0.0.1 or 2 (I forgot to)

    can't go into the admin panel and on

    what to do? don't be updated??

  2. shevchur
    Member
    Posted 1 year ago #

    woocommerce, Mystile

  3. shevchur
    Member
    Posted 1 year ago #

    updated woocommerce, and now Fatal error...

  4. mjepson
    Member
    Posted 1 year ago #

    This function requires PHP 5.1.2 minimum.

    Can you check with your host which version you are using?

  5. mechajc
    Member
    Posted 1 year ago #

    I have the same exact problem.

    Fatal error: Class 'WC_API' not found in D:\Hosting\10541710\html\wp-content\plugins\woocommerce\woocommerce.php on line 142

    I am running with godaddy as my host and using PHP Version 5.3

  6. mjepson
    Member
    Posted 1 year ago #

    Do you have any WooCommerce extensions installed?

  7. mechajc
    Member
    Posted 1 year ago #

    only plugins that are activated are WooCommerce and 404 Redirected

  8. maximus721
    Member
    Posted 1 year ago #

    I have the exact same error. First time using woocommerce, Godaddy hosting. I'm seeing scattered reports of this error on the web,but no solutions yet. 2.0.3 did not fix.

    store.gardelco.com

  9. headies
    Member
    Posted 1 year ago #

    Same problem also godaddy hosting php 5.3.6 theme Hustle. If the solution really is just switching hosting that's fine, some pointers would be appreciated. Some directions on how to reinstall the old version could also be a nice temporary fix.

  10. silvia076
    Member
    Posted 1 year ago #

    Im having the same problem with Godaddy and WooCommerce. I will give up.

    Spent the intire day trying to fix the problem, called 3 times to Goddady and its not working at all.

    I wish i could set up the free version of WooCommerce, find out how it work as a test and then set up it more professionaly with a good version of a template.

    if someone find how to fix the problem and want to help me, [Contact details redacted - You can find that level of support by hiring someone]

    Thank you

  11. headies
    Member
    Posted 1 year ago #

    I asked godaddy to switch to linux hosting they said 1-3 days done in 5 hours. Anywase much better not sure if its solved yet but it at least works most of the time and much faster. I will update tomorrow after more trials.

  12. mechajc
    Member
    Posted 1 year ago #

    let us know if it works and how to do that! :]

  13. thebutlerboys
    Member
    Posted 1 year ago #

    Me to... this fatal error is killing me right now..

  14. headies
    Member
    Posted 1 year ago #

    Yes it did work, haven't seen error sense. And it's pretty simple just call Godaddy and ask to switch to Linux hosting no extra cost.

  15. thebutlerboys
    Member
    Posted 1 year ago #

    COOOL.. I will call them in the morning

  16. L0gicaL1nsanity
    Member
    Posted 1 year ago #

    Has anyone else figured out a solution to this besides telling GoDaddy to switch to Linux hosting?

    Is the issue linked with GoDaddy Servers? We are getting the error as well, and Godaddy is also our host.

  17. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 1 year ago #

    @L0gicaL1nsanity, if your query is regarding WordPress, please create your own thread.

Topic Closed

This topic has been closed to new replies.

About this Topic