WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error - Taxonomy.php (6 posts)

  1. MightySpork
    Member
    Posted 6 years ago #

    Whenever I try to publish or save a post or a page, I get this error:

    Fatal error: Cannot use object of type WP_Error as array in /chroot/home/sporkfas/sporkfashion.com/html/wp-includes/taxonomy.php on line 1010

    I had no problems for a few days after upgrading to 2.3.1. This seems to have happened very suddenly. I have tried turning off plugins, deleting them all together, re-installing 2.3.1, then going back to 2.3, and nothing seems to help.

    I noticed a few people seem to be having this problem, but have yet to see a solution.

  2. kudelka
    Member
    Posted 6 years ago #

    I'm getting that error too.

    Any thoughts?

  3. xskier6
    Member
    Posted 6 years ago #

    I seem to not be able to get my website up and running after being able to use this site for about a month and now this. taxonomy.php has destroyed all my work if I cannot access my website. I checked with my webhost and they have sent me to wordpress and I seem to have no help what so every. no one to call or to email my troubles.

    Mighty Spork has hit rhe nail on the head. 2 months and no help. I will have to get my help from another sorurce and this web page has been hightly recomended. I would think that you would care about your reputaion. Robert Johnson godblessyou@tds.net

  4. Michael
    Member
    Posted 6 years ago #

    Also problem when creating new page
    Fatal error: Cannot use object of type WP_Error as array in /home/.torin/globalfriendsnet/pylonltd.com/wp-includes/taxonomy.php on line 1014

    Any work around? is there an old version of the file that is working?
    Thanks

  5. greatbig47
    Member
    Posted 6 years ago #

    I'm lookin for the same fix as justanewne...
    Anyone help me with a link to a fix?

    When I go to upload an image, I get....


    Fatal error: Cannot use object of type WP_Error as array in /home/.torin/globalfriendsnet/pylonltd.com/wp-includes/taxonomy.php on line 1014

  6. munkypot
    Member
    Posted 6 years ago #

    I got the same problem yesterday because of a reinstallation.
    I exported data with built-in wp feature.
    Backed up mysql tables.
    Wiped out the server folder.
    Reinstalled another clean wordpress (the version was the same).
    Imported back my data with wp feature.
    And I lost all my categories and tags (that was not a problem).

    After this I got that error when saving pages/articles and trying to upload data.

    It simply solved itself by publishing a post with a temp category and a temp tag.

    I hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic