WordPress.org

Ready to get started?Download WordPress

Forums

fatal error require() (2 posts)

  1. noooneh
    Member
    Posted 3 years ago #

    getting this message all of a sudden when i try to reach my website
    my site is :
    http://tadwin4syria.6te.net

    message:
    Fatal error: require() [function.require]: Failed opening required '/home/vhosts/tadwin4syria.6te.net/wp-includes/load.php' (include_path='.:/usr/share/pear:/usr/share/php') in /home/vhosts/tadwin4syria.6te.net/wp-settings.php on line 21

    I haven't been doing anything fancy then. no upgrading, no plugin installation. maybe some css modulating and that's it.

    any idea what the problem is? and BTW what's this include path? does it refer to some file path?

  2. noooneh
    Member
    Posted 3 years ago #

    i checked my load.php and my wp-settings.php files and they're both intact.

    opened my wp-settings.php file and found these lines starting from line 20

    // Include files required for initialization.
    require( ABSPATH . WPINC . '/load.php' );
    require( ABSPATH . WPINC . '/default-constants.php' );
    require( ABSPATH . WPINC . '/version.php' );
    
    // Set initial default constants including WP_MEMORY_LIMIT, WP_MAX_MEMORY_LIMIT, WP_DEBUG, WP_CONTENT_DIR and WP_CACHE.
    wp_initial_constants( );

    tried to comment the first four lines (to get rid of the reqire issue) and that's what i got on my website:

    Fatal error: Call to undefined function wp_initial_constants() in /home/vhosts/tadwin4syria.6te.net/wp-settings.php on line 26

    so it seems like i have to comment this also and so on and so forth. what's the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic