WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error, please help! (11 posts)

  1. clblog
    Member
    Posted 6 years ago #

    Some functions in my Dashboard is not working now, i have two error messages:

    Fatal error: Call to undefined function get_private_posts_cap_sql() in /home/clblogne/public_html/wp-admin/index.php on line 64

    Fatal error: Call to undefined function _get_category_hierarchy() in /home/clblogne/public_html/wp-admin/admin-functions.php on line 771

    Can someone help? I really don't know what to do! Thank you so much.

  2. moshu
    Member
    Posted 6 years ago #

    Is this a new install? If not, did it work before? What did you do right before the error appeared? Details...

  3. whooami
    Member
    Posted 6 years ago #

    Those 2 functions are defined in the following two files.

    wp-includes/post.php
    wp-includes/category.php

    Here is my guess - this is a recent upgrade to 2.2

    You need to go in and DELETE the files out of wp-includes/
    and then UPLOAD the new wp-includes/ files out of the 2.2 zip

  4. clblog
    Member
    Posted 6 years ago #

    Hi thanks. I continued my whole story in other's post and no one answer me, so i start my own new post. Ok, the details below:

    I did a upgrade to 2.2 by Fantastico last night, and all the Chinese turn into ????. However i read from other's blog, knowing that i need to change all the database's collation to utf8_general_c. I did that too, but it was not working. I found some says need to edit wp-config.php file, so i did and it was even worse.

    I managed to return back to 2.1.3, and it was a mess. The support from my Host suggested me to remove wordpress and reinstall again. I did removed the 2.1.3 but not able to install the wordpress 2.2 as i can't install two wordpress in the same domain. (funny! I did removed the old installation right? and there is no wordpress installed in my Fantastico).

    Anyway when i assess my blog, the page was blank and asked me to do the installation. So i follow the steps and manage to install the 2.1.3. back. Now, the Chinese text still unreadable and many other errors too. I can't use the 'manage' tool now, and i have two error messages:

    Fatal error: Call to undefined function get_private_posts_cap_sql() in /home/clblogne/public_html/wp-admin/index.php on line 64

    Fatal error: Call to undefined function _get_category_hierarchy() in /home/clblogne/public_html/wp-admin/admin-functions.php on line 771

    Sorry for the long story and really hope to solve the problems!

  5. whooami
    Member
    Posted 6 years ago #

    Here's the first hint at trouble:

    http://clblog.net/wp-includes/

    LOOK at the datestamps on those files --

    According to this other thread:

    http://wordpress.org/support/topic/119998?replies=19

    you did your upgrade via fantastico yesterday or so.. ALL the files inside wp-includes/ should have datestamps that reflect that. In fact, they dont.

    post.php wasnt replaced, neither was category.php .. etc..

  6. whooami
    Member
    Posted 6 years ago #

    you have MIXED files. Pick a version, and upload the files that it uses. You cannot have some 2.2. files, some 2.1.3 files .. it doesnt work like that.

    No-one here can help you beyond telling you what you need to do.. and Ive done that already.

  7. clblog
    Member
    Posted 6 years ago #

    Thanks whooami, but what should i do?

  8. moshu
    Member
    Posted 6 years ago #

    However i read from other's blog, knowing that i need to change all the database's collation to utf8_general_c.

    Don't read and listen to non-knowledgable bloggers.
    Read the Codex: it says explicitely NOT to change the collation if it is an upgrade. Actually it says to DELETE the two lines for charset and collation from the wp-config file!

  9. whooami
    Member
    Posted 6 years ago #

    i JUST told you. Pick a version -- Upload the correct files for that version.

    DELETE the OLD files. UPLOAD the new ones.

  10. clblog
    Member
    Posted 6 years ago #

    Hi moshu, I already did and mess up everything and that's why i am here now. Too late i know, but i am trying hard. ;(

    To whooami, 'Pick a version, and upload the files that it uses. You cannot have some 2.2. files, some 2.1.3 files', i am now using 2.1.3, but not sure what kind of files you are talking about. I am sorry that i am not a IT person, would you mind give me more details?

  11. whooami
    Member
    Posted 6 years ago #

    This isnt about being an IT person.

    Read closely:

    You have fucked your site up with these fantastico installs.

    Now, in order to fix it, you need to use an FTP client and UPLOAD the proper files to where they belong.

    You want to use 2.1.3 fine .. go download the zip off this page:

    http://wordpress.org/download/release-archive/

    Its the 5th from the bottom.

    Unzip that zip -- you will then have wordpress on your desktop.

    Using your ftp client, you go into your site and you delete the "crap" you currently have there, and you upload fresh files.

    I am NOT going to explain how to use an ftp client, that info is here:

    http://codex.wordpress.org/FTP_Clients

    Your ftp information is provided to you by your host.

    If thats not a working solution for you, then you can do it through cpanel's filemanager.. its slower, but doable.

    If thats not an option --try to get install4free to fix it for you:

    http://install4free.wordpress.net/

    Or get someone that works for money.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags