WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error / Parse error in Yaris.php when WP-OpenID activated (24 posts)

  1. Travis Tubbs
    Member
    Posted 6 years ago #

    This seems to be an interesting error as I don't see this error posted anywhere. When activating WP-OpenID 2.1.2 in WordPress 2.3.1, I get the following Fatal Error:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: parse error, unexpected '=', expecting ')' in /homepages/7/d227205292/htdocs/travistubbs.net/www/wp-content/plugins/openid/Auth/Yadis/Yadis.php on line 278

    Now, as I'm not a programming genius in any form or fashion, I have no idea why this is happening. Any thoughts and/or suggestions?

  2. Dmitrik
    Member
    Posted 6 years ago #

    I'm having same problem here.
    Can't activate the plugin cause of this.

  3. hs1pdy
    Member
    Posted 6 years ago #

    Same problem here. Mine is WP 2.3.1 with Talian 1.0 Theme

  4. Will Norris
    Member
    Posted 6 years ago #

    what version of PHP are you running?

  5. Travis Tubbs
    Member
    Posted 6 years ago #

    From what I can see, my provider is running PHP 4.4.7. It appears they are also running MySQL 4.0.25, if that's of any help. If you need any other details, let me know and I'll see what I can find. Thanks!

  6. Dmitrik
    Member
    Posted 6 years ago #

    PHP version 4.4.4
    MySQL version 4.1.22-standard

    Same with WP 2.3.1

    Should I submit a ticket to my hosting?

  7. Dmitrik
    Member
    Posted 6 years ago #

    Problem fixed.

    I submitted a ticket to support so they enable PHP 5 for me.
    They told me to add a line to my .htaccess file. Works fine now.

    Thanks for this great plugin!

  8. ericabiz
    Member
    Posted 6 years ago #

    I'm running PHP 4.4.6 on my own colo box and receiving this error. phpinfo(): http://www.erica.biz/phpinfo.php

    Does this plugin require PHP5? It doesn't say that anywhere on the plugin page.

  9. Dmitrik
    Member
    Posted 6 years ago #

    In answer to Travis' email:

    I'm with HostGator right now, so I'm not sure if it will work for other hosting companies.

    HostGator Support told me to add "AddHandler application/x-httpd-php5 .php" to my .htaccess file... and it pretty much fixed everything for me.

    Hope it helps.

  10. Travis Tubbs
    Member
    Posted 6 years ago #

    Good to hear, Dmitrik!

    It appears that what you need to add to your .htaccess file will vary from host to host. For example, my web host (1and1.com) says the following should be added:

    AddType x-mapp-php5 .php

    So, this pretty much confirms PHP5 is needed. Check with your web host to see what you need to do to have it added to your plan.

  11. Will Norris
    Member
    Posted 6 years ago #

    hmm... sounds like when I upgraded the OpenID library it introduced a PHP5 dependency. I was not aware of that, so I'll see if that was deliberate or not.

  12. Travis Tubbs
    Member
    Posted 6 years ago #

    @wnorris

    Do you want to keep this open until you determine the issue? Or resolution to the issue, I guess I should say.

  13. hs1pdy
    Member
    Posted 6 years ago #

    Hi,

    The problem solved when I upgrade PHP to v.5x. The OpenID association with username is working also.

    Regards,

  14. goyal
    Member
    Posted 6 years ago #

    Hi,

    I tried adding the PHP v5.x line to my .htaccess file and got the following error:

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 150559 bytes) in /home/amitkg/public_html/wp-admin/includes/plugin.php on line 4

    Does anyone know how to get around this one?

  15. blueyed
    Member
    Posted 6 years ago #

    To fix this for PHP4, replace line 278 (the one causing the error) like this (removing " = null"):

    -    function discover($uri, &$fetcher = null,
    +    function discover($uri, &$fetcher,

    Then it should work with PHP4, too. The library does not require PHP5, but somehow the library shipped in the plugin has been modified.

  16. ericabiz
    Member
    Posted 6 years ago #

    blueyed's fix worked for me to activate the plugin. Now to use it :)

  17. ericabiz
    Member
    Posted 6 years ago #

    When I go to the Options->OpenID with PHP4, I get:

    Warning: implode() [function.implode]: Bad arguments. in /home/myusername/domains/mydomain/public_html/wp-content/plugins/openid/interface.php on line 379

  18. ericabiz
    Member
    Posted 6 years ago #

    So, I upgraded to PHP5. And I deleted the entire openid folder after upgrading, re-downloaded, activated...and now when I go to Options->OpenID I just get a blank page. PHP's display errors is On. sigh.

  19. sherryw76
    Member
    Posted 6 years ago #

    like ericabiz, i have the same :

    Warning: implode() [function.implode]: Bad arguments. in /home/myusername/domains/mydomain/public_html/wp-content/plugins/openid/interface.php on line 379

    What should be done? I suppose we really like this plugin..

  20. DavidMeade
    Member
    Posted 6 years ago #

    I tried blueyed's fix, and I got the plugin to activate, but it doesn't actually work :-P

    Anyone know how to get a php4 friendly install going?

  21. mliubinskas
    Member
    Posted 6 years ago #

    I also got it activated, then got the implode message. It doesn't work on the blog.

    I guess it really needs mysql 5 to fly.

    Let me know if it does.

    http://www.liubinskas.com/blog

  22. oeconomist
    Member
    Posted 6 years ago #

    Okay, folks, the problem is that ampersand. Lose it. The line should be

    function discover($uri, $fetcher = null,

    In PHP, a variable fetcher is indicated with "$fetcher" and reference to that variable is indicated with "&fetcher".

    fetcher is a reference variable, and the programmer has confusedly the value of a reference variable with reference to the reference variable, and then notated this incorrectly.

  23. Will Norris
    Member
    Posted 6 years ago #

    the latest version of the plugin (v2.1.7) should have this all fixed.

  24. neotsn
    Member
    Posted 6 years ago #

    I had the same issue, and it referenced a call in widgets.php. However, the fix for me was not in widgets.php (as that was a call to Yadis.php).

    I followed @blueyed's solution (which is fixed in the code for WP-OpenID 2.1.7 already):

    To fix this for PHP4, replace line 278 (the one causing the error) like this (removing " = null"):

    -    function discover($uri, &$fetcher = null,
    +    function discover($uri, &$fetcher,

    but then to add a memory markup on line 2 of wp-content/plugins/openid/Auth/Yadis/Yadis.php with:

    ini_set("memory_limit","12M");

    Then everything worked fine.

Topic Closed

This topic has been closed to new replies.

About this Topic