WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Post List
[resolved] Fatal Error: Out of memory (allocated X) (tried to allocate Y bytes) (7 posts)

  1. StudioZ2
    Member
    Posted 1 year ago #

    Hi!
    I tried APL plugin on my developement site and it worked fine - I choose it for the job. Hten when I tried to implement it on a working site I am getting this message about Fatal Error:

    : Out of memory (allocated 151257088) (tried to allocate 4194304 bytes) in /home/tutajglo/public_html/wp-includes/cache.php on line

    I contacted my hosting company - they put up my memiry allocation up - but no change. When I try ro use "Settings->Advanced Psot List" all I got is the error mentioned above or "white page" = nothing.

    Please advise on the issue. Help.

    Lukas

    http://wordpress.org/extend/plugins/advanced-post-list/

  2. EkoJr
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry about the issue. Lately I've been working on development for the next beta, and I have multiple major fixes on the way, including this one possibly.

    However, I have posted a fix for others to follow. The issue is usually triggered in the plugin admin settings for sites that have a high number of posts and pages.

    [resolved] Maximum execution time after update - @ Post 37

    The development version has been further optimized, but this should provide a simple and quick fix.

  3. StudioZ2
    Member
    Posted 1 year ago #

    Thanks for the reply. It surprisingly shows where the issue is - I have 6000 posts an 100 pages on the site (regional news for a year), so this would cause the "blank page" result. Will try to implement the fix.

    Keep on working on the plugin - I have done reeeeaaallly long research and APL is quite impressive when it comes to advanced (but at the same time easy thanks to the interface) customization.

    Really appreciate your work.

  4. StudioZ2
    Member
    Posted 1 year ago #

    Hi!
    I have checked many times, and it still isn't working: admin page for the plugin shows nothing or after few reloads it shows the error from the title of this topic. This is the case even after implementing the fix given above. Don't know what to do.

    Don't want to be blunt here - but when are you planning to update the plugin? I am using other plugin, but APL seems to be the best solution - apart for it's not working ;). So I am hoping for this to happen soon (yes Santa - please come earlier!). Would like to help with an update of the plugin, but I am not sure if I am capable of.

    Regards, Lukas.

  5. EkoJr
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm, I figured this would end up becoming a separate issue. Unfortunately, I don't have a large environment built to test on. What line(s) is the error occurring at? It seems you left that part out.

    I'm actually getting ready to put the pre-release in the development section of my site for testers and/or troubleshooting, which I'll keep you posted on, but I can't promise you it will fix the issue. However, I would prefer to implement a fix for this before the next release.

  6. EkoJr
    Member
    Plugin Author

    Posted 1 year ago #

    Well, I posted a dev. page so I can get a fix out to the public. It'll be listed in an alternate download page that I host.

    Hope it fixes it for ya, but I guess we'll see. EkoJr - APL Download Page

  7. EkoJr
    Member
    Plugin Author

    Posted 1 year ago #

    The update has just been released as 0.3.b6

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic