WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Out of memory (allocated 42205184) (5 posts)

  1. flyhigher139
    Member
    Posted 3 years ago #

    I got this message when I was about to update my wordpress to the latest version(V3.1)

    the message: Fatal error: Out of memory (allocated 42205184) (tried to allocate 3096066 bytes) in /home/igevin/public_html/blog/wp-includes/class-http.php on line 1408

    How to fix it?

  2. Gestroud
    Member
    Posted 3 years ago #

    Add this line of code to your wp-config.php file

    define('WP_MEMORY_LIMIT', '64');

  3. flyhigher139
    Member
    Posted 3 years ago #

    Add this line of code to your wp-config.php file

    define('WP_MEMORY_LIMIT', '64');

    it doesn't work

  4. Tara
    Member
    Posted 3 years ago #

    Try:

    -deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually (one-by-one) to find the culprit.

    If you don't have access to your admin area, try deactivating them manually via FTP or phpMyAdmin.

    -switching to the default theme ("twentyten") for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

    If you don't have access to your admin area, then access your server via FTP or SFTP or whatever file management application your host provides.

    -If the above steps do not resolve the issue, Download WordPress again and replace your copies of everything EXCEPT the wp-config.php file and the /wp-content/ directory with fresh copies. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory.

  5. jonradio
    Member
    Posted 3 years ago #

    There are at least four ways to increase memory for WordPress. MichaelH has listed them nicely about half way down this thread:
    http://wordpress.org/support/topic/memory-exhausted-error-in-admin-panel-after-upgrade-to-28?replies=67

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

Topic Closed

This topic has been closed to new replies.

About this Topic