WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Related Posts
[resolved] Fatal error: Out of memory (4 posts)

  1. Zoltan
    Member
    Posted 1 year ago #

    Hello,

    I get this error every time when I set a new post to public. When I use it as a draft, there is no error, but right after wehn I clicked on the "publish" button, this error is coming up. Adn, 1-2-maybe three clicks on "refresh button in the browser" and publish succesfully... -why then giving this error?

    "Fatal error: Out of memory (allocated 50069504) (tried to allocate 78 bytes) in /var/user/wwwl/wp-content/plugins/wordpress-23-related-posts-plugin/recommendations.php on line 52"

    In the wp-config file I put this:
    define('WP_MEMORY_LIMIT', '600M');

    And on my vps installed 8 gigabyte of ram, so its should not "run-out-of-memory"...

    Thanks for help.

    Cheers, Zoltan

    http://wordpress.org/extend/plugins/wordpress-23-related-posts-plugin/

  2. silvoslaf
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Zoltan, thanks for this heads-up, I'll gladly help you out!

    How many posts have you got in your database?

    Can you check your PHP settings (if it allows you to increase to that memory size)? Allocated memory is less than your memory limit, so please check if your PHP settings allow you to set the memory limit via WordPress.

    Let us know what's up or if you have any other questions — we're here to help!

    Take care & have a nice day!

    Best,
    Silvo

  3. Zoltan
    Member
    Posted 1 year ago #

    Hello Silvoslav,

    Thank you for help!

    Yes, I added to the htaccess aline:

    <IfModule mod_php5.c>
    php_value memory_limit 200M
    </IfModule>

    also change d the wp-config.php from 600 to 200

    define('WP_MEMORY_LIMIT', '200M');

    -the error message still exist.

    I will try dissable all plugins, and enable one-by-one -- with a new post publish. -see if its coming the error again or not..

    ps, - appretiate for your help, and sorry about the awfull comment.

    Cheers, Zoltan

  4. silvoslaf
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Zoltan, no worries about anything, we're used to it. :)

    Here's some useful information — you can also try this, if you have the admin privileges on your server: http://www.php.net/manual/en/ini.core.php#ini.memory-limit

    Let me know how it goes or if the problem persists!

    Take care & have a nice rest of the day!

    Best
    Silvo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic