WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Fatal Error on upgrade (48 posts)

  1. helpplease83
    Member
    Posted 2 years ago #

    Sorry this may sound like a dumb ? but so you get in your theme in and go to wp-includes and then form the new copy of the WP 3.3 copy that wp-includes into that right?

  2. Luis Rivera
    Member
    Posted 2 years ago #

    Sorry i dont understand very well your question? Sorry for my bad english.

  3. helpplease83 - Themes are stored in wp-content/themes, not wp-includes, however themes can override WordPress settings.

  4. helpplease83
    Member
    Posted 2 years ago #

    You got my confused my includes folder is here red-earrings-usa.com/wp-includes I have a back up of my whole website with the a wp includes folder and then there's a wp includes in the wordpress as well.. So which goes where?

  5. kharim
    Member
    Posted 2 years ago #

    Just delete the wp-includes and wp-admin folder and replace them with the ones on my previous comment. That's what worked for me.

  6. helpplease83
    Member
    Posted 2 years ago #

    I guess i'm not making sense.. let me try to clarify ok.. I have a wp-includes in here red-earrings-usa.com/wp-includes which is on the root directory.. And thats where I would delete the files and refresh the new ones correct?

  7. Delete the folder wp-includes from your root directory, yes.

    You should only have one folder named that. If you have two, then your problem may be stemming from that.

  8. helpplease83
    Member
    Posted 2 years ago #

    No I only have one.. I just wanted to make sure I was doing the right thing.. So with that being said then I take the WP 3.3 includes and copy that into the red-earrings-usa.com/wp-includes right?

  9. helpplease83
    Member
    Posted 2 years ago #

    or fresh copy from a previous backup?

  10. From a fresh copy.

  11. helpplease83
    Member
    Posted 2 years ago #

    of WP 3.3 its self that downloaded? yes?

  12. I said this before. From http://wordpress.org/download

    When all else fails, download a fresh copy of the latest.zip file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

  13. 2alegacy
    Member
    Posted 2 years ago #

    I renamed the plugin folder and now able to get into admin console. I reinstalled the latest release ok. Now how do I get the plugins back. Do I have to reinstall?

  14. 2alegacy
    Member
    Posted 2 years ago #

    Found the steps that solved my problem. Mine was caused by popup domination. I deleted it. Here are the steps to fix it.

    http://www.famousbloggers.net/getting-ready-for-wordprss-3-3-solve-fatal-error-call-to-undefined-function-is_rtl.html

  15. sAMOa
    Member
    Posted 2 years ago #

    i'm thinking after wasting 3 hours that this shit dont work. i started fresh!!! wget fresh still pulls in 3.2.1...fix that crap please! so with a brand new 3.2.1 install and then automated and manual upgrade results in the same hogwash. why don't you knuckleheads have the real world test for you instead of the lab doing sterile installs. I'm so fed up with version to version errors that I just wanna scream. after all this !!! same blasted error. now... off to do some billable hours! :(

  16. NateNate
    Member
    Posted 2 years ago #

    I had the same exact fatal error, "/wp-includes/general-template.php on line 2102".

    To fix it I went into my plugins folder on my server via FTP. I just put a "-" after the plugin names to disable them. For example:

    "popup-domination" became "popup-domination-"

    After that I was allowed back into the admin. I had to go into my plugins and re-activate them but everything is working fine now. I recommend re-activating one at a time to see if it is a specific plugin or not.

  17. Matt Lovett
    Member
    Posted 2 years ago #

    Hey

    Yeh pop up domination was the cause for me also.

    Just renamed that folder and solved.

    However this means pop up domination is now disabled and I really like this plugin?

    Thanks.

  18. DO NOT EDIT CORE

    Guys, you will hate yourself in the morning more than beer goggles. :)

    That is terrible advice for people.

    I say it again:

    Make sure you've read the entire Master List post and the New Features in 3.3 Post.

    Go to your own install's about page - http://domain.com/wp-admin/about.php - to see what's new.

    And then make sure you've tried...

    - flushing any caching plugins you might be running, as well as server and/or browser caches.

    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    - switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can't log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    - manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.