WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Fatal Error on upgrade (48 posts)

  1. coachbruce
    Member
    Posted 2 years ago #

    Site has been working great for a long time. Just saw the upgrade button. Clicked it and then received the following response.

    Fatal error: Call to undefined function is_rtl() in /home/wiredtog/public_html/wp-includes/general-template.php on line 2102

    Now I can't even log into the /wp-admin.

    Totally stuck/hosed. What can I do now?

    Note: Not a coder so please be gentle :-)

    Thanks!

  2. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - re-running the upgrade via wp-admin/upgrade.php

  3. helpplease83
    Member
    Posted 2 years ago #

    The first one didn't work..

    How do you reset your plugins folder

    How re run the upgrade for wp-admin/upgrade.php

  4. helpplease83
    Member
    Posted 2 years ago #

    re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. And how do you do this grab all the files from a http://ftp.. and delete them.. and re upload wordpress

  5. coachbruce
    Member
    Posted 2 years ago #

    Still can't access the wp-admin dashboard. Any other ideas?

  6. helpplease83
    Member
    Posted 2 years ago #

    nothing so far is working.. please help..

  7. How do you reset your plugins folder

    Go in via FTP and rename the folder wp-content/plugins to wp-content/plugins-old

    Esmi linked you to how to do this: http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

  8. helpplease83
    Member
    Posted 2 years ago #

    ya.. i just followed the link.. thanks.. but nothing that he suggested is working..

    I still can't login and I continue to get this error Fatal error: Call to undefined function wp_suspend_cache_addition() in /home/content/35/7466935/html/red-earrings-usa.com/wp-includes/cache.php on line 288

  9. helpplease83
    Member
    Posted 2 years ago #

    I even deleted the plugins and that didn't work..

  10. helpplease83
    Member
    Posted 2 years ago #

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.- with this do you have to grab all the folders from a ftp deleted them.. then reinstall wordpress??

    - re-running the upgrade via wp-admin/upgrade.php - I tried this by copying the coded from a new folder of wp3.3 and pasted the code that didn't work..

  11. helpplease83
    Member
    Posted 2 years ago #

    My site is having these issues.. Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/kej0283/public_html/wp-includes/general-template.php:2101) in /home/kej0283/public_html/wp-content/plugins/whmcs-bridge/bridge.init.php on line 362

    Warning: Cannot modify header information - headers already sent by (output started at /home/kej0283/public_html/wp-includes/general-template.php:2101) in /home/kej0283/public_html/wp-includes/pluggable.php on line 866

  12. helpplease83 - Making multiple posts in a row makes it HARDER for anyone to help you.

    Please read http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list

    You may need to reset your theme (by removing all except the TwentyEleven folder)

  13. drumat5280
    Member
    Posted 2 years ago #

    I am getting the same thing.

  14. drumat5280
    Member
    Posted 2 years ago #

    I got it working by deleting this IF statement:

    2102. if ( is_rtl() )
    echo apply_filters( 'wp_admin_css', "<link rel='stylesheet' href='" . esc_url( wp_admin_css_uri( "$file-rtl" ) ) . "' type='text/css' />\n", "$file-rtl" );

    Not sure why it works now.

  15. Are you having an error with the line "wp-content/plugins/whmcs-bridge/bridge.init.php"

    Becuase THAT is a plugin. And if you're not deleteing it, it'll keep barfing.

  16. cicikelley
    Member
    Posted 2 years ago #

    I am getting the SAME thing! will follow feed to see how to troubleshoot

  17. helpplease83
    Member
    Posted 2 years ago #

    on a client's site I get this: red-earrings-usa.com
    Fatal error: Call to undefined function _fill_user() in /home/content/35/7466935/html/red-earrings-usa.com/wp-includes/pluggable.php on line 199

    Same thing on mine and ya I know WHMCS is a plugin but how do I fix the plugable.php issue?

  18. Did you do a manual upgrade?

    A FULL manual upgrade, where you delete the wp-includes folder and copy up the files from a fresh zip file?

  19. dianaf86
    Member
    Posted 2 years ago #

    @drumat5280 I'm getting the same exact error message. Where is that code located? I tried searching the general-template.php file for it, but it wasn't there.

  20. FWIW, editing core files is a terrible idea (the next upgrade will overwrite it).

    Please try the manual upgrade first: http://codex.wordpress.org/Updating_WordPress#Manual_Update

  21. helpplease83
    Member
    Posted 2 years ago #

    I have a copy of the files from that backed up a few months ago.. can I just delete the wp and re upload the files again?

  22. kharim
    Member
    Posted 2 years ago #

    Same thing happened to my blog :( Come on WordPress!!!

  23. helpplease83 - No, please do the MANUAL Update. DELETE wp-includes. Then get a FRESH copy and try that.

    kharim, same to you please :)

  24. drumat5280
    Member
    Posted 2 years ago #

    @Ipstenu I know hardcoding in this case is a bad idea, but it got me back in to the admin area so i can try other things right now.

    I am not going to panic, I know in a while this will be fixed.

    I have admin access for now so i am happy until the next release happens.

  25. helpplease83
    Member
    Posted 2 years ago #

    So just deleting the wp-includes and re uploading that correct?

  26. helpplease83 - Delete the folder off your server. Go to http://wordpress.org/download/ and download a CLEAN copy of 3.3. Upload the wp-includes from there.

  27. kharim
    Member
    Posted 2 years ago #

    I got mine to work :)

  28. kharim - Doing what?

  29. kharim
    Member
    Posted 2 years ago #

    Deleted my wp-admin and wp-includes folders and replaced them with the old files.

    Download them here

    [links removed]

    Then replace the old ones that you have :)

  30. Luis Rivera
    Member
    Posted 2 years ago #

    I do all the things i read here and anything works. I reset the plugins, remove the themes and upload a CLEAN files of WordPress 3.3 and have the same problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.