WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error on installation (20 posts)

  1. carltraininadaycom
    Member
    Posted 6 years ago #

    Hi

    Have done a search but can't find.

    Gone through all the installation steps through to final test.

    http://www.abc-hips.co.uk/blog/wp-admin/install.php

    Get the following error.

    define('DB_NAME', 'wordpress'); // The name of the database define('DB_USER', 'root'); // Your MySQL username define('DB_PASSWORD', '******'); // ...and password define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value define('DB_CHARSET', 'utf8'); define('DB_COLLATE', '');
    Warning: require_once(ABSPATHwp-admin/includes/admin.php) [function.require-once]: failed to open stream: No such file or directory in /home/vhost/abc-hips.co.uk/html/blog/wp-admin/includes/upgrade.php on line 5

    Fatal error: require_once() [function.require]: Failed opening required 'ABSPATHwp-admin/includes/admin.php' (include_path='.:/usr/local/lib/php') in /home/vhost/abc-hips.co.uk/html/blog/wp-admin/includes/upgrade.php on line 5

    Any bright spark know what's happening?

    I've tried following the file locations specified but they just send me around in circles!

    Many thanks

    Carl

  2. carltraininadaycom
    Member
    Posted 6 years ago #

    anyone able to help?

  3. obscure
    Member
    Posted 6 years ago #

    I strongly suggest that you change your password immediately.

  4. carltraininadaycom
    Member
    Posted 6 years ago #

    Thanks obscure. Changed on server and local config file but not uploaded yet until this is resolved.

    Is there not anyone who can offer help?

    Regards

  5. mholt
    Member
    Posted 6 years ago #

    I have the same error, as of about 2 minutes ago. Just tried to install it. Help :)

  6. moshu
    Member
    Posted 6 years ago #

    @carltraininadaycom,

    There seems to be something wrong with that whole thing: either with your host or with what you did.

    Normally, the install file should not display the wp-config with all the sensitive data!

    Are you sure your host has the requirements for running 2.3.2?
    How did you upload the files?

  7. carltraininadaycom
    Member
    Posted 6 years ago #

    I uploaded the XAMPPlite locally. Everything seems to work fine locally. Everything running and access ok.

  8. moshu
    Member
    Posted 6 years ago #

    That doesn't help, sorry.

    Now focus on
    a) the server
    b) the way you upload files

    AND answer the questions!

  9. carltraininadaycom
    Member
    Posted 6 years ago #

    ?!

    The files were uploaded via FTP.

    WordPress has been installed locally as I can't get access to the relevant details on the webhost server. I've then uploaded the relevant files by following the instructions.

    I'm no IT expert but I can find my way around when directed.

  10. moshu
    Member
    Posted 6 years ago #

    Your local installation and the installation on your host's server have NOTHING to do with each other. I am no IT expert either, but this is basic.
    Unless... you turned your home computer into a web server. If you didn't, stop posting about your local installation.

    What are the "relevant details" that you don't have access to?
    What was your ftp client's setting for files when uploading? ASCII or binary?

  11. mholt
    Member
    Posted 6 years ago #

    So um, I'm still sitting here with this SAME problem.

    carl: make sure your config.php starts with: <?php

    Now, can we move on to why this error occurs? I can vouch for carl in the sense that I did NOTHING to modify the files except customize config.php. (My config.php contents do NOT appear.) I jsut get that same ABSPATH error. Now why, and how does this get fixed?

    It seems to be an error with WordPress as nothing has been changed internally.

  12. moshu
    Member
    Posted 6 years ago #

    If it is an error with WP than zillion users (read: EVERY user) would be here posting about it, don't you think?

    And if you don't see what the OP sees... then you do NOT have the "exactly same error".

    99.99% of the cases it is caused by shitty server configuration or user error:
    http://wordpress.org/support/topic/151288?replies=7

  13. carltraininadaycom
    Member
    Posted 6 years ago #

    mholt: have done thanks. it removes the details

    moderator: sorry if its basic :(

    I cant easily get the details for the server for this particlar project as its dealt with through a third party.

    Call me stupid but I read that in the WordPress installation that one option was to use your own machine as a server to install MySQL and PHP which I did.

    I then uploaded the wordpress files to the standard webhost server. Maybe I misread this and should move the whole website to my local machine and use as a server?

    I cant confirm the type of FTP. It's just the standard setting within Dreamweaver but they dont say one way or the other.

  14. mholt
    Member
    Posted 6 years ago #

    moshu: Don't go explaining to me the semantecs of what defines "exact same issue" - if you are intelligent enough to read my post you'll understand that the config.php files being displayed in carl's problem is a result of an error on his part, thus not being the WordPress error at hand. So moshu, stop being critical of what our error is and instead HELP us work together to figure this error out. WordPress isn't perfect. Buck up and admit it.

    Carl: Glad to help.

    This is not a faulty server configuration. I have a slightly older version on the same server installed the exact same way, it worked fine. I've double checked server stats and everything is normal.

    So now we can identify it as a wordpress issue. Without even going into the files, I can see that ABSPATH may not be properly defined as a global variable or it is improperly implemented, since it seems to be randomly inserted at the beginning of the path with no / to separate it: "ABSPATHwp-admin/"

    This obviously is not normal. Now what can we do to get this fixed?

    Thank you

  15. homeycomb
    Member
    Posted 6 years ago #

    if you are intelligent enough to read my post you'll understand that the config.php files being displayed in carl's problem is a result of an error on his part, thus not being the WordPress error at hand.

    So um, I'm still sitting here with this SAME problem.

    and yet ..

    so he was right.

    Now that we have established that your problem is not the same as his, what IS your problem?

  16. mholt
    Member
    Posted 6 years ago #

    The same thing as he has. So what is YOUR problem?

  17. mholt
    Member
    Posted 6 years ago #

    Found the solution.

    Somehow wp-config.php was bunched into one line. It must have line breaks in it. Be sure line breaks are included where they are supposed to be. (after comments especially).

    Cheers

    (It was like when I opened the file the first time. Regardless of HOW it happened, that is the solution. Cheerio.)

  18. homeycomb
    Member
    Posted 6 years ago #

    It was like when I opened the file the first time

    you must have downloaded the "just for you" zip.

  19. moshu
    Member
    Posted 6 years ago #

    Maybe I misread this and should move the whole website to my local machine and use as a server?

    Yes, you misread it. But you should act the other way around: upload everything to the host server! Hosting a WP blog on your local machine is not an option for you at this point.

    Dreamweaver is not an option either. Never open it when working with WordPress. Get a real ftp program like FileZilla.

    (you can have a separate local installation for testing purposes)

  20. obscure
    Member
    Posted 6 years ago #


    Call me stupid but I read that in the WordPress installation that one option was to use your own machine as a server to install MySQL and PHP which I did.

    You installed MySql on PC1 (your local machine) and then WordPress on a different machine - PC2 - but the config file you posted (which is part of WP and thus on PC2) has the DB hostname as 'Localhost' - That tells WP that the database is on the same machine (PC2) as the WP install, which it isn't. It's on PC1 (your machine).
    Won't work with the wrong info entered into the config file.

Topic Closed

This topic has been closed to new replies.

About this Topic