WordPress.org

Ready to get started?Download WordPress

Forums

Twitchers
[resolved] Fatal Error on install (6 posts)

  1. capson
    Member
    Posted 1 year ago #

    Hello,
    trying to install plugin, I am using Headway theme.

    On install I get the following error

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /hsphere/local/home/c262876/presencingtheactivefeminine.com/wp-content/plugins/twitchers/twitcher.php on line 431

    Thanks

    http://wordpress.org/extend/plugins/twitchers/

  2. kevin heath
    Member
    Plugin Author

    Posted 1 year ago #

    Hi

    Can yhou check your version of php and let me know what version you are running.

    you need at least php 5.3 for this to work.

    also can you let me know what version of wordpress you are using. I hae not yet tested it in wordpress 3.5

    thanks
    Kevin

  3. capson
    Member
    Posted 1 year ago #

    Hello Kevin,

    I have:
    php 5.2.17
    wordpress 3.5

    unfortunately for me my hosting company does not provide php 5.3

    Thanks

  4. kevin heath
    Member
    Plugin Author

    Posted 1 year ago #

    Hi

    Yeah I thought it would be an issue with the php version with your error code.

    php5.3 added a lot bore power to the PAAMAYIM_NEKUDOTAYIM (::) that is not recognised by previous versions of php.

    You might want to ask your hosting company to upgrade as php 5.3 is pretty stable now as it's been around for a while and it also closed some serious security issues that was in php 5.2 and earlier.

    Kevin

  5. capson
    Member
    Posted 1 year ago #

    Thanks for the reply Kevin,

    I did ask my hosting company if they would upgrade me to 5.3 but they were not able to do this, this might be what finally gives me the extra push I need to change hosting companies.

    I hope to use your plugin in the near future.

  6. Pixel Girl
    Member
    Posted 1 year ago #

    Hi Kevin,

    I just got the same error, and I am running php 5.3.13 and WordPress 3.5.1

    Help! :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic