WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error on Greeny 1.0 theme (5 posts)

  1. tarab
    Member
    Posted 7 years ago #

    Trying to upload a new theme...other themes are working ok...but this particular one, when I go to view my site after attempting uploading it, is just a white screen with the following message:

    "fatal error: Call to undefined function: language_attributes() in /home/withmett/public_html/wp-content/themes/greeny-10/header.php on line 2"

    I'm not sure what version of WordPress I'm on...It's whatever was the newest version in April of 2006.
    I've deleted and re-uploaded several times, not sure what else to try. Other themes are working properly, but the one I'd prefer is not. Do i need to change something on line 2 in that document the error refers to? Line 2 currently says:

    Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    Any ideas?

  2. whooami
    Member
    Posted 7 years ago #

    I'm not sure what version of WordPress I'm on...

    How not surprising, especially when your version is viewable in the source of your actual site, the source of all your feeds, and on the bottom of every page in your administration area.

    For the record, you are on 2.0.1, a very exploitable version.

    <meta name="generator" content="WordPress 2.0.1" /> <!-- leave this for stats -->

    While I cannot explain why that theme is looking for that function; I did look and that particular function, language_attributes, is nowhere inside any of that theme's files -- its probably a case of another function being called that relies on that function.

    Since language_attributes was introduced in the 2.1.x branch your current version will spit out that error.

    I'm not going to track down the problem any more than that. I suggest you upgrade away from your hackable version

    You have 2 choices:

    You can upgrade to 2.0.10 and still see that error, but atleast you'll be using the most current in the 2.0.x branch (at which point, I might be compelled to help further figuring out what specifically you can do to use that theme)

    Or you can upgrade to 2.2.1 where you will not see that specific error.

  3. tarab
    Member
    Posted 7 years ago #

    whooami,

    I do appreciate you letting me know what I need to do. Thank you.

    I don't appreciate the derogatory comment ("How not surprising..." etc). I'm just getting back into this after a year+ of not looking at it at all, and when there is a lot to learn and figure out when one is relatively new to doing something (yes, some of us are still new to blogging and setting up web sites), it is easy to overlook things that are staring one directly in the face due to being overwhelmed with a bunch of new terminology and a bunch of new everything. I spent a lot of years in support-oriented industries and I would never talk to someone like that no matter how dumb I thought their question was or how ignorant they appeared to be.

    Anyway thanks again for the help and have a great day.

  4. whooami
    Member
    Posted 7 years ago #

    tarab,

    I'm sorry if you took offense. I see from your profile that you have been registered here a year, and while your post history is admittedly sparse I assume thats when you set up your blog. I certainly hope that you didnt set up a blog one year ago and just let it set, that's worse than using exploitable code and actually checking in occasionally.

    I wont, however, apologize, for not being surprised. That you, like so many others dont/cant/arent able/simply refuse do "_insert what you want here_" to acquaint yourself with the very bare minimum of what it takes, and yes, it generally takes knowing what version you are currently running, to administer WP simply doesnt surprise me.

    If you see that as a knock, so be it.

  5. tarab
    Member
    Posted 7 years ago #

    I understand what you're saying, and I can appreciate where you're coming from. I was quick to ask for help because I was overwhelmed and didn't pay attention. Nobody's perfect. As I said, when someone is new and overwhelmed it's easy to end up not seeing something that's so blatently obvious; that just doesn't really necessitate rudeness is all I was saying.
    ...and yes, I let it sit there for over a year untouched, for a lot of reasons, none of which I'm required to explain before asking for help with an error message.

    I upgraded to the new version and all is well. I won't take anymore of your time. Thanks again for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags