WordPress.org

Ready to get started?Download WordPress

Forums

Code Insert Manager (Q2W3 Inc Manager)
[resolved] Fatal error: ob_start(): Cannot use output buffering (8 posts)

  1. elysii
    Member
    Posted 1 year ago #

    Until yesterday, this plugin runs very well on my blog. But, yesterday, my pages with inserted code have this problem:

    Fatal error: ob_start(): Cannot use output buffering in output buffering display handlers in ../www/blog/wp-content/plugins/q2w3-inc-manager/q2w3-inc-manager.php on line 1135

    The other pages are not affected.

    It seems to me that the problem comes from the update of Advanced Custom Fields. So I desacvated that plugin, but this can't resolve the problem.

    Please help me!

    PS.
    The php version of my server is 5.4 (defined in .htaccess file).
    In my wp-config.php, the 'WP_MEMORY_LIMIT' is 256M, and "WP_CACHE" is set to "true".

    http://wordpress.org/extend/plugins/q2w3-inc-manager/

  2. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    Hello!
    Try to add this line:
    php_value output_handler none
    to wordpress .htaccess file before
    # BEGIN WordPress words.

  3. elysii
    Member
    Posted 1 year ago #

    Thank you!

    I've tried it, but the problem remains.

    Below is the "PHP Server / PHP.ini Info" of my system. Perhaps it is useful:

    PHP Version: 5.4.6
    PHP Memory Usage: 32.79 MB
    WordPress Admin Memory Limit: 256M
    WordPress Base Memory Limit: 256M
    PHP Actual Configuration Memory Limit: 128M
    PHP Max Upload Size: 64M
    PHP Max Post Size: 64M
    PHP Safe Mode: Off
    PHP Allow URL fopen: On
    PHP Allow URL Include: Off
    PHP Display Errors: On
    PHP Display Startup Errors: Off
    PHP Expose PHP: On
    PHP Register Globals: Off
    PHP MySQL Allow Persistent Connections: Off
    PHP Output Buffering: 4096
    PHP Max Script Execution Time: 120 Seconds
    PHP Magic Quotes GPC: Off
    PHP open_basedir: not in use
    PHP XML Support: Yes
    PHP IPTC Support: Yes
    PHP Exif Support: Yes

  4. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    Let's try to play with PHP Output Buffering value.
    Try to variants:
    php_value output_buffering On
    and
    php_value output_buffering 0

  5. elysii
    Member
    Posted 1 year ago #

    Many thanks!

    They didn't work either.

    But there's something tricky: the shortcodes work in the short pages; only the long pages have this problem. (Unfortunately, I am used to making length articles.)

  6. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    Hm...
    May be the buffer size is too small for big pages?..
    Let's increase it:
    php_value output_buffering 8192
    or
    php_value output_buffering 16384
    or
    php_value output_buffering 32768

    Also try to disable caching plugin!

  7. elysii
    Member
    Posted 1 year ago #

    From 8192 to 1048576, the same problem. However, your suggetion brought me to some experiments, and by making them, I noticed that the problem lies maybe in the accumulation of old versions of my pages. So I deleted them all, and optimized the database. Result: Your plugin works magnificently as before.

    Sorry to disturb you because of a problem caused by my ignorance.

    I think this topic can be marked as resolved.

    Thank you very much!

  8. Max Bond
    Member
    Plugin Author

    Posted 12 months ago #

    Fine! )

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic