WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error - Memory size exhausted (17 posts)

  1. mvanpatten
    Member
    Posted 6 years ago #

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 252212 bytes) in /home/goinglik/public_html/wp-includes/cache.php on line 4

    http://goinglikesixty.com

    WordPress 2.3.1

  2. Jeremy Clark
    Moderator
    Posted 6 years ago #

  3. mvanpatten
    Member
    Posted 6 years ago #

    thanks, I did a search, but didn't hit the right combination of terms I guess.

    Now take back your slap on the wrist, K?

  4. mvanpatten
    Member
    Posted 6 years ago #

    Ok Jeremy... I searched the forum you suggested and nobody has a fix. So the next time you flame somebody for bad search terms, you might just shut up unless you have a link to a fix.

    Forums are for help. Not flames.

  5. Jeremy Clark
    Moderator
    Posted 6 years ago #

    My first reply was not in any way a flame, I was just pointing out the fact that searches usually turn up the answer, I then proceeded to give you a link that would help.

    But you'll need to contact your host, very rarely are end users able to change any php settings. You can try this in your .htaccess file
    php_value memory_limit 16M

    And just for your information the link that was given in the second post in this topic spelled it out very clearly, oh it also happens to be the first in the search results as well.

  6. mvanpatten
    Member
    Posted 6 years ago #

    Bluehost changed the damn PHP engine from PHP 4 to PHP 5 which means that just about every WordPress blog out on Bluehost is going to break. The WordPress Database Backup plugin will no longer work with PHP 5 so I moved it to a temporary folder on the server in order to deactivate it. I also set the PHP memory limit to 20M in two PHP files (cache.php and pluggable.php) which got you back up and running for now.

  7. navomedia
    Member
    Posted 6 years ago #

    i have also the same error while installing at localhost:
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 98304 bytes) in C:\Program Files\VertrigoServ\www\projects\blogs\wp-admin\includes\schema.php on line 37.
    Any body can help me?

  8. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Edit your php.ini file and look for this
    memory_limit = 8M
    Change it to this
    memory_limit = 32M

  9. tbronson
    Member
    Posted 6 years ago #

    This is maybe a little off topic, but I just ran into a similar PHP memory exhausted error, I recently upgraded my server to PHP5, and I've already upped my PHP memory limit twice, from the default 8M to 10M then 12M, to deal with problems in other apps. Now it seems it should go up to 32M...

    My question is based on what I've gathered, that simply upping the PHP mem limit is not too sound a fix, that these memory errors generally result from poor coding (memory leaks?). How accurate and relevant is this? Is it not good to just up the limit?

    Thanks!

  10. midori
    Member
    Posted 6 years ago #

    Hi there,

    I get the same problem with the "upload" part of the admin, it's apparently the miniature creation that causes problem, because the image itself is uploaded, and NO, I cannot augment memory being on a shared hosting. Did someone at least try to find another solution than "read the other threads" (that I did) and "augment the memory" (that I can not) ?

  11. rockinrav
    Member
    Posted 6 years ago #

    hey.. The same problem with me... I just changed the WAMP server version and it worked...

    I think this is due to aome PHP version... try getting the latest PHP version and this problem might vanish..

    All the best..

    Rav

  12. Jeremy Clark
    Moderator
    Posted 6 years ago #

    If the problem is with the thumbnail creation or lack of it then it's most likely that the host doesn't have GD support compiled into php. GD is a graphics extension for php that allows resizing and all that.

    As far as doing something about the memory limit if you can't increase it then try disabling all plugins that you don't need.

  13. midori
    Member
    Posted 6 years ago #

    Nope, GD2 is compiled, according to the phpinfo. As for the plugins, having no plugin or just the "Get recent comments" does not change anything. I am sending a mail to the hosting support to see what they can do for the version of PHP. Thanks both for the ideas.

  14. maasaiwawarrior
    Member
    Posted 6 years ago #

    Hi,
    Where do you find the php.ini? I also have to change the momemry size. Please assist.

  15. BernardBorealis
    Member
    Posted 6 years ago #

    The php.ini file is not always available on every host. If you are hosted with Bluehost, you can click on the 'PHPConfig' option within the cpanel and choose to install the master php.ini file. It will install as php.ini.default, so you'll have to rename it to php.ini. Bluehost is pretty smart about the settings, so it should automatically have the memory_limit = 32M But you can always change it to anything else if needs be. If you are not with Bluehost, you may want to check with your host to see if they allow the usage of a php.ini file.

  16. josesan77
    Member
    Posted 5 years ago #

    Hi,
    I am interested in a fix that does not require to edit the php.ini file because I am not allowed to do that on a server which is not my own.
    Please help.

  17. josesan77
    Member
    Posted 5 years ago #

    Hi again!

    I found some solution at this site(s):
    wordpress.topic1

    http://www.kongtechnology.com/2008/01/10/allowed-memory-size-of-8388608-bytes-exhausted-and-wordpress-shows-a-blank-page/

    wordpress.topic2

    Read those carefully! I hacked the install.php according to the text and inserted the line as it is suggested:
    ini_set(’memory_limit’,'32M’);
    This resulted in syntax error for T_STRING on line 2 of install.php which is the brand new insertion. So I tried to fix the syntax error:
    ini_set(’memory_limit’, ’32M’);
    Seemed to be better then the previous and then I got this error message:
    "Warning: ini_set() has been disabled for security reasons in /../../wp-admin/install.php on line 2"

    This means that I can not fix this problem (have no rights to do). I have to move my files to an other host :(
    I hope you are luckier! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags