WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Maximum execution time of 300 seconds exceeded (12 posts)

  1. Daisyhead
    Member
    Posted 8 years ago #

    I recently upgraded to WP 2.0 and then decided I wanted to go back to 1.5. Everything has gone smoothly except for importing of my SQL database. I am currently getting the following error:

    Fatal error: Maximum execution time of 300 seconds exceeded in /usr/local/cpanel/base/3rdparty/phpMyAdmin/libraries/read_dump.lib.php on line 91

    I saw in another post that someone made mention of overriding PHP's default execution time by adding the following to the wp-config.php file:

    set_time_limit('120');

    But I'm unsure how or where to add this to the wp-config file. Can someone help me out? I also have a support ticket out to my host to see if they can temporarily up the limit but with it being a holiday weekend I don't know if they will respond any time soon and I'd really like to get my blog back up and running.

    Thank you in advance!

  2. What you are seeing is a server report, not a WordPress error. Most hosting providers set maximum PHP execution times to prevent system abuse. Your server's maximum is set to 300 seconds, and a large database may take more than 300 seconds to upload. You may have to contact your hosting provider and ask them to restore your database backup for you, or temporarily increase the maximum PHP execution time.

    Out of curiosity, why do you want to go back to v1.5?

  3. Daisyhead
    Member
    Posted 8 years ago #

    Thanks for the info. I have a ticket out to my host but I don't think it will get answered any time soon.

    I just didn't like the interface with 2.0 or the functionality, not to mention a lot of my plugins didn't work with 2.0 including the CG-Archives plugin I use to do my archives. I realized I was quite happy with the version I was running and thought it would be a snap to revert back to. Boy was I wrong.

  4. Daisyhead
    Member
    Posted 8 years ago #

    So adding the following line: set_time_limit('5000');

    To my wp-config.php isn't going to fix the problem either? Dammit.

  5. So adding set_time_limit('5000'); to my wp-config.php isn't going to fix the problem either?

    No, because the "problem" is related to your server's configuration of PHP, not WordPress.

  6. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Daisyhead - an alternative is to open the .sql file in something like WordPad, Notepad++ or another plaintext editor and then copy and paste huge chunks into the SQL query box.
    Laborious but it works.

    Another method is to upload the sql file into your website and then use the command line to import it.

    Better still, upoad the sql file and then send the location of that file to your host and ask them to import it for you.

  7. linuxale
    Member
    Posted 8 years ago #

    Hi Guys,
    somebody have a definitive solutions for this problem?

    Thanks
    Linuxale

  8. vkaryl
    Member
    Posted 8 years ago #

    The definitive solution is to either:

    1. Get your host to increase the server time limit;
    2. Upload the sql file and ask your host to do the db import for you from the file;
    3. Use the "chunks of text in the sql query field" option (I've been able to do up to 7000 lines before the server timeout lands);
    4. Download BigDump from http://www.ozerov.de/bigdump and see if that is workable on your server.

  9. linuxale
    Member
    Posted 8 years ago #

    Hi vkaryl,
    Hi don't know how to do the point 2 and 3!

    Can you explain its!

    Thanks
    Linuxale

  10. linuxale
    Member
    Posted 8 years ago #

    I'v tried the bigdump script and it works perfectly! But after a dump/restore the upload continue to fail!

    I installed WP2 too! But the problem persist. So I think the problem itsn't WP but some mine configuration! But Which conf!?!

    Fatal error: Maximum execution time of 30 seconds exceeded in /var/wp2/wp-admin/admin-functions.php on line 1754

    Thanks
    Linuxale

  11. linuxale
    Member
    Posted 8 years ago #

    I'v found a workaround!

    So what I do.
    I Dump all the db and only the wp_personal_options table.
    I reset the db and reconfigure wordpress1.5 with :
    http://myblog/wp-admin/install.php

    Ok at this point a retry to upload a file and I get a success! Uahuuu.
    Ok so I dump only the wp_personal_options table and restore the old one. The Upload begin to fail.

    So I think There is something in the wp_personal_options table!
    I like to understand what. I'v look to the differece between the table but I have no idea of this behaviour.
    If somebody can help me to understand why... I will be happy!

    See You
    Linuxale

  12. webmedi
    Member
    Posted 8 years ago #

    I need increase execution time. Please give me process.
    Error Massage occured like this:
    Fatal error: Maximum execution time of 30 seconds exceeded in /home/herboint/public_html/admin/admin_bonus.php on line 185

    Regards,
    Dilip

Topic Closed

This topic has been closed to new replies.

About this Topic