WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error: line 21 of widgets.php FRESH INSTALL (4 posts)

  1. scottoliphant
    Member
    Posted 6 years ago #

    Just did a fresh install twice of 2.5, and if i click the widgets button from the design panel in the admin, i get the following error:
    Fatal error: Only variables can be passed by reference in D:\WEB\BCRC\wp-admin\widgets.php on line 21
    everything else seems to be fine. No plugins installed. Default theme.
    PHP 5, mysql, IIS.

  2. scottoliphant
    Member
    Posted 6 years ago #

    seems like it may be related to php 5.0.5 and up, a little googling revealed similar errors in other cms's

  3. scottoliphant
    Member
    Posted 6 years ago #

    upgraded to php 5.2.5 and worked like a champ.

  4. bebizzy
    Member
    Posted 6 years ago #

    Not a big fan of this fix. I'm not sure my host will upgrade and potentially blow up dozens of sites for my blog.

    Someone at WP going to fix this one?

Topic Closed

This topic has been closed to new replies.

About this Topic