WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error in wp-config.php (7 posts)

  1. 1911
    Member
    Posted 9 years ago #

    Has anyone come across this error message before:
    Fatal error: Failed opening required '//wp-settings.php' (include_path='.:') in //wp-config.php on line 20

    If so, what should I be looking for.
    The only edits I have made were to the three following lines in wp-config.php:
    define('DB_NAME', 'dbname); // The name of the database
    define('DB_USER', 'myname'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password

  2. RaulTBC
    Member
    Posted 9 years ago #

    If the MySQL database is not on the computer you are accessing the blog from you will have to change the DB_HOST definition to the host name of the database.

    --Raul

  3. livatlantis
    Member
    Posted 9 years ago #

    Something similar thing happened to me, try reuploading wp-settings.php. Else, the entire thing ;)

  4. RobertPlantFan
    Member
    Posted 9 years ago #

    I am getting this same error. I have installed the wp files in a subdirectory. I edited the wp-config file using the information my host gave me. I also tried the DB HOST line using the localhost value that is ok 99 percent of the time, as well as changing it to the MySQL server name that the host gave me. Both generated the same result. I tried reuploading the files as livatlantis suggested and still got the same result. The file structure is correct. Any suggestions?

  5. DianeV
    Member
    Posted 9 years ago #

    LZ fan: have you tried the domain name in place of "localhost"? That's often what's needed with shared web hosting.

  6. RobertPlantFan
    Member
    Posted 9 years ago #

    Yes. I tried the domain name, the mysql server and leaving it at localhost. All three gave me the same result.

  7. RobertPlantFan
    Member
    Posted 9 years ago #

    Oy. So I've spent the last few days modifying the wp-config file to see if I could stumble on something that worked. I saw a post several pages back that gave instructions to modify the ABSPATH lines at the bottom (below where it says STOP EDITING). I finally ended up putting in the long absolute path to my directory in the first line. I believe this may work for others having this problem. I got the error message to change at least. This time it tells me my host isn't running PHP version 4.1. I'll just go cry now...

    Anyway, this may be of some help to the others with this problem. I modified the lines thusly:

    define('ABSPATH',"/nfs/cust/8/2/3/beadso/web/blog".dirname(__FILE__));
    require_once(ABSPATH.'wp-settings.php');

    The stuff in the quotes I stumbled on by looking at my log files from my greymatter installation.

    I'm kind of new with this kind of thing so it may or may not be the right thing, but I'm stuck now without the proper PHP version.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.