WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error in WP 3.1-alpha (9 posts)

  1. scribu
    Member
    Posted 3 years ago #

    Don’t use the conditional query tags (is_page, is_post(), is_*) prior to init. In 3.0 and earlier, this merely failed quietly. In 3.1 this will produce a fatal error.

    http://wpdevel.wordpress.com/2010/08/30/dont-use-the-conditional-query-tags-i/

  2. BuddyPress is currently guilty of this in the 1.2 branch of code, and will be fixed asap.

  3. scribu
    Member
    Posted 3 years ago #

    Yeah, if someone finds any other plugins in this situation, add them to the tags on this thread.

  4. Frederick Townes
    Member
    Posted 3 years ago #

    @John James Jacoby, is there an update here? :)

  5. The BuddyPress fix for this has been bumped to BuddyPress 1.3, which won't be released until much later this year. The relevant BuddyPress trac ticket is http://trac.buddypress.org/ticket/2609

  6. Frederick Townes
    Member
    Posted 3 years ago #

    Thanks Paul.

  7. CircleReader
    Member
    Posted 3 years ago #

    Very disappointed that this has been deferred. I'd like to start working with BuddyPress, but am completely stopped by this. Please do consider moving this up in the process!

  8. The reason for bumping this particular issue was that it is going require a significant overhaul of key functions which would have been too risky to put into BP 1.2.6. Sorry!

  9. CircleReader
    Member
    Posted 3 years ago #

    Really too big a job to do quickly, huh? Bummer.

    But thanks for all the hard work you've put into BuddyPress - I'm looking forward to getting it running when 1.3 is further along!

Topic Closed

This topic has been closed to new replies.

About this Topic