WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error in word (8 posts)

  1. yogesh_gamer
    Member
    Posted 2 years ago #

    I am getting fatal error in my Wordspress Dashboard where I received wordpress.org feeds automatically.
    Error: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /home/yogeshga/public_html/wp-includes/class-simplepie.php on line 11707

  2. Patrick Nommensen
    Member
    Posted 2 years ago #

    Hi, there are some other posts that deal with this issue. Keep in mind they are a bit old but they should still be helpful.

    http://wordpress.org/support/topic/fatal-error-allowed-memory-size-of-33554432-bytes-exhausted-2?replies=24

    Here's also some useful information: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

  3. yogesh_gamer
    Member
    Posted 2 years ago #

    I already entered define('WP_MEMORY_LIMIT', '64M'); to my wp-config.php. should i change it to define('WP_MEMORY_LIMIT', '96M'); ???

  4. Patrick Nommensen
    Member
    Posted 2 years ago #

    There are a few other things you could do. (copied from the post I referenced)

    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    4. Talk to your host.

    I doubt you will need more memory than that, but you could give it a whirl. You can also ask your host what the max is. Keep in mind you probably don't want to set it to max if you have other sites on the same server. If you're still getting errors I would recommend contacting your host. Perhaps someone with more experience in this topic can provide help.

  5. yogesh_gamer
    Member
    Posted 2 years ago #

    There is no php.ini file in public_html folder. So I tried 3rd option. I got 500 Internal Server Error.

  6. Patrick Nommensen
    Member
    Posted 2 years ago #

    Please note, this setting may not work if your host does not allow for increasing the PHP memory limit--in that event, contact your host to increase the PHP memory limit. Also, note that many hosts set the PHP limit at 8MB.

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

  7. yogesh_gamer
    Member
    Posted 2 years ago #

    okay. I will contact my Host. How much Memory I need to resolve this issue?
    64MB or 96MB?
    I requested for 64 MB.

  8. yogesh_gamer
    Member
    Posted 2 years ago #

    I installed this plugin: http://wordpress.org/extend/plugins/wp-memory-usage/

    and results is:
    PHP Version : 5.3.10 / 64Bit OS
    Memory limit : 32 MByte
    Memory usage : 30.48 MByte

    How much Memory i needed to resolve every similar issue?
    I deactivate all plugins except two plugins "Under Construction" and "WP Memory Usage". My PHP memory is already 22MB. :(

Topic Closed

This topic has been closed to new replies.

About this Topic