WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error in upgrade.php - urgent (8 posts)

  1. KathrynBassett
    Member
    Posted 5 years ago #

    Help! I'm out of commission til this is solved.
    http://www.virginiagenealogyblog.com//wp-admin/upgrade.php

    Warning: require(../wp-load.php) [function.require]: failed to open stream: No such file or directory in /home/virginia/www/www/wp-admin/upgrade.php on line 18

    Fatal error: require() [function.require]: Failed opening required '../wp-load.php' (include_path='.:/usr/local/php5/lib/php') in /home/virginia/www/www/wp-admin/upgrade.php on line 18

    I've followed the instructions little by little and am sure I did them all right. What now?

  2. meesha
    Member
    Posted 5 years ago #

    How did you upgrade and from what version to what version?

    The best overall fix at this time is to do a clean manual install of what ever version you are upgrading to. I have 8 sites I'm upgrading from 2.6.5 to 2.7 and after the third one (using WP automatic upgrade plugin) I stopped doing an automatic upgrade and started doing it manually, eliminated 99-100% of upgrade issues.

  3. KathrynBassett
    Member
    Posted 5 years ago #

    2.3.2 and followed these instructions http://codex.wordpress.org/Upgrading_WordPress_Extended - I've upgraded several other sites before but this is the first for awhile (they are all at 2.3.2 at present).

  4. whooami
    Member
    Posted 5 years ago #

    you have another error on your front page, that may help more in diagnosing/eliminating the problem.

    the error you pasted suggests a file is missing, but I browsed to it on your site, and wp-load is where it ought to be.

    the remote_post error on your front page is something other folks have experienced.

    http://wordpress.org/search/Call+to+undefined+function+wp_remote_post?forums=1

    in looking through those other posts, you probably want to start at the bottom as they have replies.

  5. KathrynBassett
    Member
    Posted 5 years ago #

    the error you pasted suggests a file is missing, but I browsed to it on your site, and wp-load is where it ought to be.

    Which is where? I was looking for it and don't see it anyplace either on my computer or on the server so was figuring that it being missing is why I can't update. While I wait for an answer on that one, I'll go look at the link you gave.

  6. whooami
    Member
    Posted 5 years ago #

    http://www.virginiagenealogyblog.com/wp-load.php

    Fatal error: require() [function.require]: Failed opening required '../wp-load.php' (include_path='.:/usr/local/php5/lib/php') in /home/virginia/www/www/wp-admin/upgrade.php on line 18

    its there. :)

    or rather it was, before you started re-uploading :)

  7. KathrynBassett
    Member
    Posted 5 years ago #

    Thanks, and I think I figured out my problem (will know for sure when I finish uploading). When I copy/pasted from the temp folder I unzipped to, I copy/pasted the "root" files to my backup folder instead of my working folder (fortunately I also have a backup on external hard drive). I'll post back in a few minutes.

  8. KathrynBassett
    Member
    Posted 5 years ago #

    Yeah! It works now, thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.