WordPress.org

Ready to get started?Download WordPress

Forums

IMDb link transformer
[resolved] Fatal Error in popup.php on line 104 (5 posts)

  1. mrmadhatter
    Member
    Posted 1 year ago #

    Hola,

    Firstly, I have to say that this plug-in is truly amazing. It's saving me so much time and effort. Thank you very much, your hardwork is really appreciated. You really are a gifted guy :)

    I can get everything to work except the highslide functionality. Everytime I click a movie link I get a fatal error (see below). Is it me being stupid? I'm using the BoxOffice theme so I wonder if that makes any difference...?

    Fatal error: Call to a member function imdbid() on a non-object in .../wp-content/plugins/imdb-link-transformer/inc/popup.php on line 104

    Kind regards,
    Matt

    http://wordpress.org/extend/plugins/imdb-link-transformer/

  2. jcv
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Matt,

    Thanks for your kind words!

    You downloaded highslide plugin and moved it into the right folder, did you?

    If so, please report the basics: what’s the name of the movie you have a problem with, is the issue happening for all movies, which imdb address are you using (akas.imdb.com, french imdb, uk imdb), have you tried the « Debug mode » (general options-advanced-misc-debug mode), what are your IMDb LT, PHP, apache and wordpress versions, have you tried to unactivate all your plugins but IMDB LT, etc.

    Do not hesitate to share a link to your website.

  3. mrmadhatter
    Member
    Posted 1 year ago #

    Hi JCV,

    Thanks for the response and apologies for the late response myself (I've been really busy recently). I tried your suggested fixes, such as deactivating all other plugins, but to no avail unfortunately.

    The versions I have are:
    PHP 5.3
    Apache 2.2
    WordPress 3.4.2

    I could get the highslide working when I included movie details in a post using the [imdbltid] tags, it just didn't work when I used the < !--imdb--> tags.

    Saying all of this, I've just updated to the latest plugin version and now the [imdbltid] function throws up the following error multiple times within each post:

    Warning: filemtime() [function.filemtime]: stat failed for /home/content/75/9924975/html/films/wp-content/cachett1753496.search in /home/content/75/9924975/html/films/wp-content/plugins/imdb-link-transformer/class/mdb_base.class.php on line 276

    I assumed it was a cache issue so I disabled the cache and everything works now, even < !--imdb--> functionality :) I'm pretty sure I'm missing something obvious but the Cache and Photo directories are set up OK with the correct permissions. It's only a smallish private site though (which is why I can't share the link unfortunately) so unless I'm missing something obvious then I think I'm just going to leave the cache disabled.

    Thanks for your help JVC, and for the awesome plugin. It's great to see that you're still working on updates too :)

    Matt

  4. jcv
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Matt,

    Thanks again for your kind words!

    Just a thought: did you correctly end your Cache directory "(absolute path)" setting with a trailing slash?

    According to the error you have, it might be possible you didn't. That could explain the error.

    Also try to reset all settings; perhaps something weird happened.

    Hope it helps!

  5. mrmadhatter
    Member
    Posted 1 year ago #

    Hi JCV,

    What a muppet I am. You're right, I was missing the trailing slash. Everything works flawlessly now, brilliant.

    Thanks a lot JCV, I really appreciate your help! You've made my day :)

    Kind regards,
    Matt

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic