WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms Highrise CRM
[resolved] Fatal Error HighriseAPI.php on line 135 (4 posts)

  1. JustinSchneiderman
    Member
    Posted 10 months ago #

    Hi,

    I am receiving the following error when a form is submitted on the site...

    Fatal error: Uncaught exception 'Exception' with message 'People not found' in /home/content/26/11127126/html/wp-content/plugins/gravity-forms-highrise-crm/inc/HighriseAPI.php:135 Stack trace: #0 /home/content/26/11127126/html/wp-content/plugins/gravity-forms-highrise-crm/inc/HighriseAPI.php(400): HighriseAPI->checkForErrors('People') #1 /home/content/26/11127126/html/wp-content/plugins/gravity-forms-highrise-crm/inc/HighriseAPI.php(376): HighriseAPI->parsePeopleListing('/people/search....', 25) #2 /home/content/26/11127126/html/wp-content/plugins/gravity-forms-highrise-crm/inc/HighriseAPI.php(340): HighriseAPI->findPeopleBySearchCriteria(Array) #3 /home/content/26/11127126/html/wp-content/plugins/gravity-forms-highrise-crm/gravity-forms-highrise-crm.php(1216): HighriseAPI->findPeopleByEmail('justin@testing....') #4 /home/content/26/11127126/html/wp-content/plugins/gravity-forms-highrise-crm/gravity-forms-highrise-crm.php(1148): GFHighriseCRM::export_feed(Array, Array, Array, Object(HighriseAPI)) #5 [internal function]: G in /home/content/26/11127126/html/wp-content/plugins/gravity-forms-highrise-crm/inc/HighriseAPI.php on line 135

    I also see that same error in the dashboard if I go to the Highrise CRM page and click to edit any of my feeds.

    I have updated to the latest version of the plugin 2.0.3 as well as WordPress 3.6 AFTER the problem occurred to see if this would resolve it but it did not.

    No new plugins were added or updated prior to the problem occurring, and just to be clear yes it was originally working without issue. No obvious changes have been made to the site that would likely cause the issue.

    Any ideas? Please advise. Thank you.

    http://wordpress.org/plugins/gravity-forms-highrise-crm/

  2. B Hays
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Justin,

    Just to clarify, the plugin was working properly previously? After the upgrade to 2.0.3 things broke?

    The error leads me to believe it's an issue with Highrise, or your Highrise account. For the API key you've generated, is that on an admin account?

  3. JustinSchneiderman
    Member
    Posted 10 months ago #

    Hi B Hays,

    It broke before the upgrade, the upgrade was an attempt to fix it.

    However I have since determined that my client changed their Highrise account URL/Subdomain which is what caused the issue.

    I will be sure to check that first thing next time.

    Thanks for the quick response though, and for making an awesome plugin!

  4. B Hays
    Member
    Plugin Author

    Posted 10 months ago #

    You're welcome, glad to hear it's working.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.