WordPress.org

Ready to get started?Download WordPress

Forums

Genealogy
[resolved] Fatal error Genealogy Plugin (8 posts)

  1. Shonari
    Member
    Posted 3 years ago #

    Fatal error: Call to undefined function get_the_post_thumbnail() in /home1/root/public_html/website/wp-content/plugins/genealogy/genealogy.php on line 994

    I keep getting that error when i try to add a family member

    I cannot add extra fields for additional information

    Family member not diplaying when i have added a family member.

  2. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    The plugin requires at least WordPress 3.0; the function get_the_post_thumbnail() was added in WordPress 2.9, so I think you need to upgrade.

  3. Shonari
    Member
    Posted 3 years ago #

    I am using wordpress 3.1.2. Ive tried the plugin on 3 different sites

    I keep getting a thumbnail error in the backend

    When i click 'view family member' I get a 404 error that the page does not exist.

    When i try to add an extra field for additional information, nothing happends, it just highlight the one thats already there.

  4. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    Ah, well then, have you tried using the default twentyten theme? It likely will work there.

    Newer themes with support for get_the_post_thumbnail() should work. I forgot to think about older themes that may not support it.

    Regarding adding an extra field, try using Firefox or Chrome browsers and let me know if that works. It may be an issue with Internet Explorer browsers.

  5. jcnapw
    Member
    Posted 3 years ago #

    Some issue here - I'd really like to use the plugin but apparently it isn't supported by my theme (based on your diagnosis above).

    For others in the same boat as me, is there a quick way to modify the theme to make it compatible?

    Thanks

  6. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    I think adding the following to your theme's functions.php file would work:

    if(!function_exists('get_the_post_thumbnail')) {
    	function get_the_post_thumbnail() {
    		return false;
    	}
    }
  7. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    I have just added a check in the plugin code to fix this issue in version 1.2.1. Please let me know if this resolves that issue.

  8. jcnapw
    Member
    Posted 2 years ago #

    Family member info now shows up correctly with the update - so far so good! Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags