WordPress.org

Ready to get started?Download WordPress

Forums

Flattr
[resolved] Fatal Error - flattr.php, line 14 - Version 0.9.16 (9 posts)

  1. leanderbraunschweig
    Member
    Posted 3 years ago #

    When trying to activate the plugin I get

    Parse error: parse error, unexpected T_CONST, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /srv/www/vhosts/authentic-minds.com/httpdocs/strudo/mediatribune/wp-content/plugins/flattr/flattr.php on line 14

    Since it doesn't point anywhere else (another php not included by the plugin) I posted here...

    Line 14
    const VERSION = '0.9.16';

    Any ideas?
    Other plugins I use (active):

    All in One SEO Pack 1.6.12.1
    Disqus Comment System 2.50
    Duplicate Post 1.1.1
    FeedBurner FeedSmith 2.3.1
    Media Tags 2.2.9.2
    Reveal IDs for WP Admin 1.1.7
    SNV Facebook Like Button 1.6
    Sociable 3.5.2
    TinyMCE Advanced 3.2.7
    WordPress.com Stats 1.7.3
    WordPress Database Backup 2.2.2
    WordPress Related Posts 1.2
    WP-Polls 2.50
    WP-RSSImport 4.4.9

    http://wordpress.org/extend/plugins/flattr/

  2. VoxPelli
    Member
    Plugin Author

    Posted 3 years ago #

    Which version of PHP are you using?

  3. leanderbraunschweig
    Member
    Posted 3 years ago #

    Currently running 4.4.0 - that a problem?

    I also tried another plugin called "FlattrButton standalone" in order to test for any errors and indeed got myself another one:

    Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /srv/www/vhosts/authentic-minds.com/httpdocs/strudo/mediatribune/wp-content/plugins/flattrbutton-standalone/flattrbutton-standalone.php on line 20

    Any clues?

  4. Yes, the plugin requires PHP 5.

  5. leanderbraunschweig
    Member
    Posted 3 years ago #

    Allright James, thanks for the info.

  6. Honestly, I recommend contacting your hosting provider and asking them to upgrade to PHP 5.

    The PHP 4 branch was discontinued in August of 2008, and 4.4.0 was released in July of 2005, so your host is way behind.

    WordPress 3.2, due the first half of 2011, will require PHP 5.2 or later, so you might as well ask now.

    If your hosting provider cannot accommodate you, and insists that you use a version of PHP that was released over five years ago and discontinued over two years ago, I recommend taking your business elsewhere.

  7. VoxPelli
    Member
    Plugin Author

    Posted 3 years ago #

    I also suggest upgrading to PHP 5.2 or later, but I've also updated the Flattr plugin to correctly detect PHP 5 - so you wont see a parse error in the future, the plugin just simply wont work.

  8. leanderbraunschweig
    Member
    Posted 3 years ago #

    I've also updated the Flattr plugin to correctly detect PHP 5

    Thanks VoxPelli, that should do the trick for everybody else.

    If your hosting provider cannot accommodate you, and insists that you use a version of PHP that was released over five years ago and discontinued over two years ago, I recommend taking your business elsewhere.

    True James, thanks. Since the current Server is for setup-purpose only, I won't be troubled once I have migrated and my site goes live. Nonetheless they ought to keep a close eye on their product in order for their customers not to run into any trouble (like I did) - I've given them a heads-up, hopefully something will happen...

    Thanks for the support guys, really appreciate it!

  9. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags