WordPress.org

Ready to get started?Download WordPress

Forums

Simple Real Estate Pack
[resolved] Fatal Error during upgrade (16 posts)

  1. kfawcett
    Member
    Posted 2 years ago #

    Tried upgrading and got this.

    Plugin failed to reactivate due to a fatal error.

    Warning: require_once(/home/mysite/public_html/wp-content/plugins/simple-real-estate-pack-4/includes/Class_srpWidgets.php) [function.require-once]: failed to open stream: No such file or directory in /home/mysite/public_html/wp-content/plugins/simple-real-estate-pack-4/srp.php on line 48

    Fatal error: require_once() [function.require]: Failed opening required '/home/mysite/public_html/wp-content/plugins/simple-real-estate-pack-4/includes/Class_srpWidgets.php' (include_path='.:/usr/share/pear:/usr/share/php') in /home/mysite/public_html/wp-content/plugins/simple-real-estate-pack-4/srp.php on line 48

  2. everwill
    Member
    Posted 2 years ago #

    Same here. It brought down every site on that server.

    I'd love to reinstall the old version until this is resolved.

  3. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    You can get the previous version here http://wordpress.org/extend/plugins/simple-real-estate-pack-4/download/

    I'll take a look at the issue as soon as I get to the office.

  4. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry about it ALL! For some reason a whole folder with files didn't get uploaded with the last commit. I have re-committed the update under version 1.2.1. Should work now.

  5. kfawcett
    Member
    Posted 2 years ago #

    No problem, it didn't bring down my server or sites, but the plugin stopped working. Luckily I had backups. :)

  6. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    @kfawcett - could you please confirm if 1.2.1 works for you?

  7. kfawcett
    Member
    Posted 2 years ago #

    Sure, it'll be later on today before I can upgrade. I'll let you know.

  8. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    drum-roll... holding my breath :)

  9. everwill
    Member
    Posted 2 years ago #

    I'm about to try it now. The old 1.2.0 is there but not active. What I should do is delete that that one and install the new one. But I think I'm going to live dangerous and attempt an upgrade.

  10. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    It doesn't matter how you update... the initial 1.2.0 was missing a whole folder... so, by doing and automatic update should simply grab all the files this time.

  11. everwill
    Member
    Posted 2 years ago #

    Max,

    You are the man.

    BTW, I've loved this plugin for quite a while but the school portion has NEVER worked for me. Any tips?

  12. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    @everwill - give me an example of what you do that doesn't work. May be an exact shortcode you're trying to use.

  13. everwill
    Member
    Posted 2 years ago #

    I was checking to see if the upgrade worked.

    I looked here:
    http://mount-vernon-homes.com/welcome/mount-vernon-va/

    And see no businesses.

    So for the heck of it, I made a new post:

    http://mount-vernon-homes.com/2011/07/15/grocery-stores/

    Exact same location ... but it doesn't work.

    To answer your question, this shortcode:

    [schoolsearch city="Mount Vernon" state="VA" zip="22309" groupby="gradelevel" output="table"]

    Gets me this result:

    http://mount-vernon-homes.com/schools-mount-vernon/

    Warning: curl_exec() has been disabled for security reasons in /var/www/vhosts/nesbittrealty.com/httpdocs/wp-content/plugins/simple-real-estate-pack-4/includes/srp-functions.php on line 385
    Something went wrong. No data is being returned from education.com.

    There are no schools within 3 miles radius of this location.

  14. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    curl_exec() is a standard PHP function, which in your case has been disabled by your hosting provider. See if you can ask them to activate it for you.

  15. everwill
    Member
    Posted 2 years ago #

    I've got a virtual dedicated server at Godaddy. Are there security risks to enabling this functionality?

  16. Max Chirkov
    Member
    Plugin Author

    Posted 2 years ago #

    I guess, like anything else, it could be used in malicious ways if you install third party code that you unfamiliar with... I don't really know what are the security risks here... try googling and see what you find out. Here is general information on cURL library.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic