WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal Error during loading index page. (11 posts)

  1. danieltubul
    Member
    Posted 4 months ago #

    Oh well, And here it goes again.
    I have uploaded my site to the new domain : DanielTubul.com
    from danieltubul.coi.li
    and now it have this error :

    Fatal error: Call to undefined function wp_initial_constants() in /home/dantu/domains/danieltubul.com/public_html/wp-settings.php on line 33

    what should i do?
    Thanks.
    Daniel.T

  2. jonradio
    Member
    Posted 4 months ago #

    Although this one sounds more like an incomplete WordPress install, I do want to be sure you've read the relevant parts of http://codex.wordpress.org/Moving_WordPress because you can't just upload a site from one domain to another without doing some other work.

  3. esmi
    Forum Moderator
    Posted 4 months ago #

    Try re-uploading all files & folders - except the root wp-config.php & .htaccess files and the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  4. danieltubul
    Member
    Posted 4 months ago #

    Exept the wp-config.php only??? or another files?

  5. bemdesign
    Member
    Posted 4 months ago #

    Upload everything from the new WordPress files except the following: "wp-config.php" file, ".htaccess" file and the "wp-content" folder.

  6. danieltubul
    Member
    Posted 4 months ago #

    Well I have done all and now all seems to be "fine"
    but i have this error : "Error establishing a database connection"
    in the front page : DanielTubul.com

  7. bemdesign
    Member
    Posted 4 months ago #

    Have you created the database on the server for WordPress to connect to? Have you configured your wp-config.php correctly? Do you have the correct database username, database password, and database location (url or IP address to the databse)? Your wp-config.php file needs this to be able to connect WordPress to the database.

  8. danieltubul
    Member
    Posted 4 months ago #

    Well it seems that you were right.
    fixed most of the parts.
    but now, as always i have another problem.
    the website front page is loading all fine
    but the sub pages arent working well.
    DanielTubul.com
    They are not loading.
    but if you go right into them:
    http://danieltubul.com/?p=2
    they have some error.
    Maybe domain issue?

  9. bemdesign
    Member
    Posted 4 months ago #

    Possibly. But check your WordPress permalink settings and click save/update. This should flush out any bad redirects.

  10. danieltubul
    Member
    Posted 4 months ago #

    Okay! problem solved! :)
    thanks!

  11. danieltubul
    Member
    Posted 4 months ago #

    @bemdesign :
    could you give me some hand on another issue:
    https://wordpress.org/support/topic/help-with-iframe-issues?replies=1

Reply

You must log in to post.

About this Topic

Tags

No tags yet.