WordPress.org

Ready to get started?Download WordPress

Forums

Postie
[resolved] Fatal Error - during (8 posts)

  1. gdisalvo
    Member
    Posted 10 months ago #

    Hello,

    bug found during post test debug.

    Fatal error: Out of memory (allocated 52166656) (tried to allocate 513 bytes) in the wp-includes/class-pop3.php on line 372

    Is this a one time or is this something new?

    http://wordpress.org/plugins/postie/

  2. gdisalvo
    Member
    Posted 10 months ago #

    Wyane,

    Here is a message from 8 years ago. Do you think this is a cause of a memory issue?

    http://wordpress.org/support/topic/cant-automate-email-post-checking?replies=13

    Found a fix:

    1) open 'postie-functions.php' in /wp-content/plugins/postie
    2) edit the following on line 56:
    CHANGE
    'post_title' => $subject,
    TO
    'post_title' => preg_replace("/'/","\'",$subject),

    This changes the ' into \' - and that was the issue. This should be updated in the source as well - programmers please review this

  3. gdisalvo
    Member
    Posted 10 months ago #

    Wayne,

    Another attempt - Reset email to unread in the INBOX. and now the MIME is having an issue. Can the attachmenst be too large? 3M - I never had issues when on WP 3.5 and older postie

    Warning: preg_match() [function.preg-match]: Get subpatterns list failed in /##/wp-content/plugins/postie/mimedecode.php on line 411

    Fatal error: Out of memory (allocated 43778048) (tried to allocate 3101844 bytes) in /##/wp-content/plugins/postie/mimedecode.php on line 435

  4. gdisalvo
    Member
    Posted 10 months ago #

    Wayne,

    I removed the two PDF files and postie is working. Can you look into why a PDF does not get translated and attached to the post?

    The setting have application - No banned extensions. I thought standard postie takes word and pdf attachments?

  5. Wayne Allen
    Member
    Plugin Author

    Posted 10 months ago #

    The memory errors are from PHP running out of memory. Try increasing the amount of memory. http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

  6. Wayne Allen
    Member
    Plugin Author

    Posted 10 months ago #

  7. gdisalvo
    Member
    Posted 9 months ago #

    Hi Wayne,

    Already done. These settings have been live like this for 8 months.
    I used your plugin in the past and it loaded attachments. This time there were issues with attachments. When I removed them it loaded the post. But I think it was something else like a backup. It could have been my backups running against the database slowing and hogging things up while the postie was trying to read and move it over. I am not sure but if I see the attachments not getting on the post, I will open a ticket again.

    Thanks,

  8. Wayne Allen
    Member
    Plugin Author

    Posted 9 months ago #

    Thanks for following up.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.