WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Fatal error: Class 'WooCommerce_Widget_Cart_Kriesi' not found in /home/regiun92/ (9 posts)

  1. danlupu2012
    Member
    Posted 1 year ago #

    Hi,
    I installed theme forest theme -replete and then
    WooCommerce - eCommerce Shop plugin.
    And I have this error Fatal error: Class 'WooCommerce_Widget_Cart_Kriesi' not found in /home/regiun92/public_html/deliafashion.ro/wp-includes/widgets.php on line 324.
    What can I do?
    Thank You

    http://wordpress.org/extend/plugins/woocommerce/

  2. Roy Ho
    Member
    Posted 1 year ago #

    This is not a WooCommerce issue but one with your theme. Your theme is trying to call a class that is not found. That is a custom class from your theme. I suggest you ask your theme developer about this.

  3. hwaitaeng
    Member
    Posted 1 year ago #

    Hello,

    This is directed to splashingpixels.

    I am using your MiO theme and am getting a similar error.

    Fatal error: Class 'SP_WooCommerce_Widget_Cart' not found in /home/content/92/10217192/html/withussone/wp-includes/widgets.php on line 324

    Any help, please?

    Thank you (:

  4. Roy Ho
    Member
    Posted 1 year ago #

    @hwaitaeng - simple, update your theme for 2.0 compatibility! And in the future please do not post other themes support question here. Post it to the theme's support forum.

  5. Lexunder
    Member
    Posted 1 year ago #

    Same problem here with the splashingpixels. What is the step by step process to fix the problem? I can't login to my WP anymore. Where is the splashingpixels forum?

  6. Roy Ho
    Member
    Posted 1 year ago #

    If you can't login, it would mean you updated WooCommerce to 2.0 before you updated the theme to 2.0 to be compatible.

    It depends on if you purchased a theme or not. If you did, you already have access via your member dashboard if not, you need to sign up.

  7. Lexunder
    Member
    Posted 1 year ago #

    I purchased the theme. The problem I can't access the WP anymore to update the updated theme.

  8. Roy Ho
    Member
    Posted 1 year ago #

    No worries, Please visit the proper support forum and we'll help you there.

  9. Knights Templates
    Member
    Posted 1 year ago #

    Here's a quick fix if anyone gets the above problem..

    Using your favourite FTP app.. (mine is filezilla)

    1) Browse in the left panel and find an old 'plugins/woocommerce' directory from a recent backup (pre update to have the old version of the woocommerce plug-in in..)

    2) FTP into your site, go to:

    wp-content/plugins/

    3) Delete the woocommerce directory - may take a mo..

    4) Upload your old woocommerce directory into the plugins folder and..

    Now you can log-in to your admin, go plug-ins and reactivate your woocommerce plug-in - Website back up!

    If your current theme will not take the woocommerce update, then don't update!

    Note, if you don't have an old copy of the woocommerce plugin folder, you can still delete the folder via FTP which will then at least allow you to log-in to your wordpress site, change the 'appearance/themes' to a compatible one and then add the new version directly from your site in the plugins/add new

    Good luck

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.