WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Class 'ftlink' not found... (11 posts)

  1. schematix
    Member
    Posted 11 months ago #

    I am new to WPand probably made a dumb mistake but I was hoping someone could point me in the right direction to the fix.

    I have upgraded WP several times in the past with no issues but on the upgrade to 3.6 yesterday my footer page stopped working with the error message in the title.

    I can't find any reference in any of the source code to 'ftlink'. The footer.php file only contains a small block of code:

    <?php
    $ftlink = new ftlink();
    <?php do_action('wp_footer'); ?>

    Any thoughts? If I comment out the ftlink line of code the error message goes away but my footer doesn't show up.

    I am also having formatting issues with one of the pages now too. The website is http://www.machinecontrolgroup.com, Page=Connect. The Contact information is supposed to be on the right side bar, the form is supposed to be on the left and the footer is also missing.

  2. esmi
    Forum Moderator
    Posted 11 months ago #

    Can you replicate the problem using the default Twenty Thirteen theme with all plugins deactivated?

  3. schematix
    Member
    Posted 11 months ago #

    I DO NOT get the error message with Twenty Thirteen and all plug-ins disabled.

    However, the original footer doesn't show up.

  4. esmi
    Forum Moderator
    Posted 11 months ago #

    What happens if you switch back to your old theme (leaving all plugins inactive)?
    Where did you download this theme from?

  5. schematix
    Member
    Posted 11 months ago #

    When I switched back leaving the plug-ins off the only change I noticed was that a previously private page had become public, and that an older version of the 'Connect' page because the most recent version (???).

    The theme came from a paid web developer.

    The original error message is still present though.

  6. esmi
    Forum Moderator
    Posted 11 months ago #

    Then it sounds like your theme is the issue. You need to go back to its developer for support with this.

  7. schematix
    Member
    Posted 11 months ago #

    What's the risk of downgrading WP back to 3.5? Is it even possible? I don't have a pre-upgrade DB or site backup (my bad, I know).

    I've attempted to contact the original developer already but no luck yet.

  8. schematix
    Member
    Posted 11 months ago #

    Another odd thing I'm seeing and don't know if it's related is that I was always seeing a WP admin bar across the top. Now i see an empty bar. Probably related?

  9. esmi
    Forum Moderator
    Posted 11 months ago #

    What's the risk of downgrading WP back to 3.5?

    The chances of your site being hacked/defaced increases exponentially.

    Now i see an empty bar. Probably related?

    Yes - almost certainly.

  10. schematix
    Member
    Posted 11 months ago #

    Thanks for the advice esmi.

    Hopefully this is something the dev can help me with easily.

  11. delevega
    Member
    Posted 11 months ago #

    Esmi is right! Do not downgrade. WP 3.6 is excellent. Just fix your theme. Check out Blankslate. Very cool base theme to build off of.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.