WordPress.org

Ready to get started?Download WordPress

Forums

Easy Watermark
[resolved] Fatal error: Class 'finfo' not found (4 posts)

  1. Ian
    Member
    Posted 1 year ago #

    Hi there, installed Easy Watermark plugin fine.

    Changed settings and uploaded image to use for watermarking.

    Tried to watermark existing images, but getting this error:

    Fatal error: Class 'finfo' not found in /home/XXXXXXXX/domains/XXXXXXX.com/public_html/XXXXXXXXX/wp-content/plugins/easy-watermark/lib/EasyWatermark.php on line 915

    What does this mean?

    Thanks for your time, cheers, Ian

    http://wordpress.org/extend/plugins/easy-watermark/

  2. Ian
    Member
    Posted 1 year ago #

    I tested and can manually use the "Add watermark" per image, but have several hundred so not really an option.

    Hopefully you can help figure out why the bulk option doesn't work, thanks.

  3. szaleq
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Ian,

    This error is caused by the fact that you has no 'fileinfo' extension enabled on your server. This extension is used by EasyWatermark class to get an information about image mime type, etc., but it is only needed if the class has only image path given. Normally wordpress has all needed information in the database so the mime type should also be taken from there and no finfo function should be used... I'll try to figure out what's happening there, but if you're able to enable fileinfo extension for your php, it will work for sure.

    Regards

  4. sharonlipinski
    Member
    Posted 1 year ago #

    I just contacted Hostgator and they upgraded me to Php version 5.3. Now it works. Thanks! I'll send a donation your way, because your plugin was a huge help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic