WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Album
Fatal error: Cannot use string offset as an array in ... (11 posts)

  1. mrcariboo
    Member
    Posted 9 months ago #

    Hi,

    Since a few days, I'm getting this message:

    Fatal error: Cannot use string offset as an array in /home/xxx/public_html/web/wp-content/plugins/facebook-albums/fbalbum.php on line 177

    But only for one of my albums. Others are working fine... I verified album links but all is OK. When I'm saving my page again, it works the first time, then I'm getting this error again.

    If anyone knows what's going on...

    Thank you!!

    http://wordpress.org/plugins/facebook-albums/

  2. mrcariboo
    Member
    Posted 9 months ago #

    Ok, I removed this latest 2.05 version and reinstalled Version 1.0.7.3.
    It works but some thumbnails are not showing. But still better than the error message.

    If anyone has a clue...

    Thanks!

  3. OneUniqueQueen
    Member
    Posted 8 months ago #

    I'm getting the same error. This just happened when I updated my wordpress to version 3.8 and updated the plugin to version 2.0.5.2.

    If anyone has any idea what this is and how to fix it please let me know.

    Thanks.

  4. mrcariboo
    Member
    Posted 8 months ago #

    Latest version that is approximatively working is 2.0.2

    New uptdate 2.0.5.2 posted 4 days ago is even worse with error message...

  5. mglaman
    Member
    Plugin Author

    Posted 8 months ago #

    Know what would be helpful? PHP versions. I develop in 5.4 and WP 3.6, because I stopped WordPress dev and I maintain this plugin just to be nice.

    I'm not going to optimize this plugin for 3.8. If you'd like it, then please consider making a donation

  6. mrcariboo
    Member
    Posted 8 months ago #

    Ok, I understand.
    My PHP version is PHP 5.2. That's maybe the answer as you're developing for PHP 5.4.
    Thanks anyway.

  7. mglaman
    Member
    Plugin Author

    Posted 8 months ago #

    This is fixed in 2.0.5.3.

  8. mrcariboo
    Member
    Posted 8 months ago #

    Well, it worked fine the first time I opened my page. Then, I'm getting this message:

    Warning: array_reverse() [function.array-reverse]: The argument should be an array in /home/www/3f2646feb862412ca49f0b656ba88d88/web/web/wp-content/plugins/facebook-albums/fbalbum.php on line 177

    Warning: Invalid argument supplied for foreach() in /home/www/3f2646feb862412ca49f0b656ba88d88/web/web/wp-content/plugins/facebook-albums/fbalbum.php on line 179

    In case it can help, I'm using WordPress 3.5.1 and PHP 5.2.

  9. mglaman
    Member
    Plugin Author

    Posted 8 months ago #

    mrcariboo its probably because of stale caches. Can you please visit the settings page, click clear caches (next to the setting) and see if that works?

  10. mrcariboo
    Member
    Posted 7 months ago #

    Dear Mglaman,
    Sorry for the late reply. My computer has been out of order for a while.

    When I clear the cache, it works, but just once. Then again, the error message...

  11. mglaman
    Member
    Plugin Author

    Posted 7 months ago #

    mrcariboo, that's odd. Can you email me: nmd.matt@gmail.com so I can help further?

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.