WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: cannot redeclare... problem (9 posts)

  1. sito
    Member
    Posted 8 years ago #

    Hi,

    I have searched the forum high and low for a possible solution to the problem I am having on a fresh install of WordPress 1.5.2. While there are many references to similar issues, none seem relevant so far, so here is my addition to the list.

    Essentially when I am trying to install the FeedWordpress plugin but I keep getting the error:

    Fatal error: Cannot redeclare is_syndicated() (previously declared in /home/donorweb/htdocs/wp/wp-content/plugins/feedwordpress.php:116) in /home/donorweb/htdocs/wp/wp-content/plugins/feedwordpress.php on line 116

    The strange thing is that the same plugin installs and works flawlessly on another installation (on a different server) of WordPress 1.5.2, which in fact uses many more plugins.

    I am beginning to suspect that it may be a server issue. On the server that gives the error: PHP v 4.3.10, Apache 4.3.31, MySQL 4.0.25. On the server that has no problems: PHP 4.4.0, Apache 1.3.33, MySQL 4.0.25-standard.

    Can someone spot something wrong with the two specifications? Or any suggestions on what else I can try?

    Thanks heaps!!

  2. masquerade
    Member
    Posted 8 years ago #

    You probably accidentally enabled the plugin twice, so the code is being loaded twice. WP-Medic can help you out with disabling the plugin without accessing wp-admin

  3. sito
    Member
    Posted 8 years ago #

    Hi,

    Thanks for the suggestion! I will give it a shot.

    Before asking my question, I have seen another post on the forum which mentioned duplicate entries in the database, so I have dropped the whole database so did a fresh install. But hopefully wp-medic can provide more diagnostic information.

  4. sito
    Member
    Posted 8 years ago #

    Hi,

    Just want to update after using wp-medic. wp-medic can be used to enable/disable plugins, but it does not really provide any additional information, so my problem remains open.

  5. masquerade
    Member
    Posted 8 years ago #

    Make sure you're running the latest feedwordpress, maybe there's a bug of some sort. Verify your uploads, and if you know how, double check that the plugin isn't being loaded twice according to your database.

  6. sito
    Member
    Posted 8 years ago #

    Hi,

    The version of feedwordpress that I am using is 0.96, which is the latest. I must also point out that this version does work on 2 other installations (different server).

    The plugin has not been loaded twice - the wp database only shows one instance of feedwordpress.

    Any other suggestions?

  7. Nevrotik
    Member
    Posted 8 years ago #

    The "Cannot redeclare function" error seems to be related to php 5. Many plugins doesn't work on my side when using php 5, since they "seem" to be written in the php 4 way. When I use insteed php 4.4, everything works well.

    Maybe the error given to you by php 4.3.1 is induced by same problem ?

  8. JRSpice
    Member
    Posted 8 years ago #

    I've yet to see this issue resolved to anybody's satisfaction, regardless of what form it takes. I too have been experiencing this - I've now run into my 2nd plugin that throws this error upon trying to administer it. No, it's not in the db twice. Are there any other suggestions besides check the version of php??

    I've spent an inordinate amount of time trying to track the problem. I've ensured all calls are "_once" and found only 2 places the plugin is being referred to - one is in the header itself where the hyperlink calls the plugin so you can administer it, and then the screen that should come up when you click the hyperlink. Surely the header isn't declaring the function that the plugin admin screen is then trying to (re)declare.

  9. nine7sicks
    Member
    Posted 8 years ago #

    Cannot_redeclare is caused by the same code trying to be loaded twice. So, I suggest trying the include_once() statement.

    The include_once() statement includes and evaluates the specified file during the execution of the script. This is a behavior similar to the include() statement, with the only difference being that if the code from a file has already been included, it will not be included again. As the name suggests, it will be included just once.

    Hopefully that fixes the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic