WordPress.org

Ready to get started?Download WordPress

Forums

MP Tweet List
Fatal error: Cannot redeclare class OAuthException (8 posts)

  1. Karesansui
    Member
    Posted 1 year ago #

    Hello, on one of my sites I gave this a try with this result.

    Fatal error: Cannot redeclare class OAuthException in /home/deb9580n5/domains/autorijschoolpolman.nl/public_html/wp-content/plugins/mp-tweet-list/twitteroauth/OAuth.php on line 8

    Unfortunately, when you activate the new version (yet without the ley's) it brings down all following widgets with this very same message!?

    Thanks,

    http://wordpress.org/extend/plugins/mp-tweet-list/

  2. Rudolph Smits
    Member
    Posted 1 year ago #

    I have the same problem too, so it looks like a general issue.
    http://www.vakantiehuisverhuur.eu.
    De-activating the plugin solves the problem, but I hope this is only very temporarily.

  3. MikesPickz
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    Version 3.1 has just been released that should fix the OAuthException error. The problem was a compatibility issue with other plugins that use Twitter authentication. Let me know if Version 3.1 works for you.

    Mike

  4. Karesansui
    Member
    Posted 1 year ago #

    Yep,
    This version works for me !

    Thanks,

  5. Rudolph Smits
    Member
    Posted 1 year ago #

    Unfortunately not for me. It gives the following error:
    Fatal error: Cannot use object of type stdClass as array in /home/deb48514/domains/magoster.nl/public_html/wp/wp-content/plugins/mp-tweet-list/mp-tweet-list.php on line 267

    After update I deleted the plugin and re-installed again. After activating it gave this error immediately.

    The plugin has been de-activated again.

    As it works for Karesansui I donĀ“t know whether this is an generic issue. Mike, i hope to hear from you again!

    http://www.magoster.nl

  6. Adrian Toll
    Member
    Posted 1 year ago #

    Just to let you know, Mike's point about other Twitter plugins worked for me - I was using MP Tweet List to replace the now-defunct Tweet Blender, but hadn't deactivated Tweet Blender beforehand. When I deactivated Tweet Blender the error disappeared.

  7. Rudolph Smits
    Member
    Posted 1 year ago #

    Adrian, Mike

    Whatever caused it, it works again. I followed Adrian's advise and de-actived some other plugins. As it works again I take my hands off from the other plugins. Just to be sure. ;-)

    Thanks for your advise!

  8. danger89
    Member
    Posted 9 months ago #

    I got still the same issue, can't there by any fix that will check if the class is already defined before re-defining the OAuthException class again :(!?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic