WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Cannot instantiate non-existent class... (4 posts)

  1. tobsen
    Member
    Posted 8 years ago #

    As I posted here: http://wordpress.org/support/topic/64069?replies=8

    I have a problem when posting or eding a post in wordpress 2.0.2.
    error message:

    Warning: weblog_ping(): Unable to access /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/class-IXR.php in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 851

    Warning: weblog_ping(/srv/www/htdocs/web293/html/t/privat/blog/wp-includes/class-IXR.php): failed to open stream: No such file or directory in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 851

    Warning: weblog_ping(): Failed opening '/srv/www/htdocs/web293/html/t/privat/blog/wp-includes/class-IXR.php' for inclusion (include_path='.') in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 851

    Fatal error: Cannot instantiate non-existent class: ixr_client in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 854

    Any way to solve it?

  2. tobsen
    Member
    Posted 8 years ago #

    no idea?
    it is going on m nerves...
    i tryed to change folder permissions, but nothing occured.

    Would be VERY kind of you at all

  3. tobsen
    Member
    Posted 8 years ago #

    Some additional information:

    "Private" or "Draft" checked on the right:
    "Save" > everything is all right
    "Save and Continue Editing" > everything is all right
    "Publish" > Error

    "Publish" checked on the right:
    "Save" > Error
    "Save and Continue Editing" > Error
    "Publish" > Error

    I can do this again and again, same result.

    No idea at all? Is there nobody who can tell me, what this Error-Code means?

  4. tobsen
    Member
    Posted 8 years ago #

    well, apache is case sensitiv.
    and in my ftp there was a class-ixr.php

    but wordpress requested class-IXR.php (als we can see in the ERROR-Message above).

    So, with a simple "rename" everything was fine.

    Funny stuff...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.