WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error: Call to undefined function: wp_get_referer() (12 posts)

  1. mtgarden
    Member
    Posted 7 years ago #

    This is the error I received when I tried to run upgrade.php:
    Fatal error: Call to undefined function: wp_get_referer() in /home/mtgarden/public_html/wp-admin/upgrade.php on line 70

    Any suggestions?

  2. yosemite
    Member
    Posted 7 years ago #

    Try re-uploading wp-admin/ (after deleting existing one)?

  3. mtgarden
    Member
    Posted 7 years ago #

    No success.

  4. Gallora
    Member
    Posted 7 years ago #

    I have the same problem. I've removed and re-uploaded wp-admin with no success as well.

    The funny thing is, I used these exact same files to upgrade another install of WP with no problem at all!

    Anyone have any wisdom here?

  5. NewSaga
    Member
    Posted 7 years ago #

    I'm not having the 'exact' error, but am getting the 'fatal error' message. Here is what's been suggested to me so far...
    http://wordpress.org/support/topic/81775?replies=2
    I'm just in the process of trying it.

  6. raffy
    Member
    Posted 7 years ago #

    Is this a bluehost.com install perchance? I had the same problem and had to roll back to 2.0.3.

  7. NewSaga
    Member
    Posted 7 years ago #

    Raffy - I'm on bluehost.com; but my original problem that made me decide to upgrade is that I couldn't login to my admin pagel -> kept getting a blank screen.

  8. Gallora
    Member
    Posted 7 years ago #

    No - I use Jatol. As I said, oddly enough these exact same files allowed me to upgrade another install of WP without a problem.

    And thanks NewSaga, I'll check the other thread for some tips.

  9. jdybka
    Member
    Posted 7 years ago #

    I had that same error. I logged out of admin, logged back in, and browsed to upgrade.php and it worked then.

    Not on bluehost though.

  10. mtgarden
    Member
    Posted 7 years ago #

    I am not on Bluehost. I have tried to log out and log in several times. Now, my theme is broken.... Need to find a way to fix this soon. what is the wp_get_referer() trying to do?

  11. okorioth
    Member
    Posted 7 years ago #

    Ditto here, going from 2.02 to 2.04..followed instructions
    same exact error and I am hosting on my own machine.

  12. mtgarden
    Member
    Posted 7 years ago #

    Solved it by redoing the instructions. I deleted just about everything, then reinstalled and it worked. My theme is broken a bit though.... That's minor otherwise.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags