WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Call to undefined function wp() in wp-blog-header.php on line 14 (8 posts)

  1. ashodhiya
    Member
    Posted 3 years ago #

    My wordpress blog at http://earnwithanand.com/Wordpress was not showing content of any single post. While trying to resolve I started deactivating plugins one by one. As soon as I deactivated wp-super cache plugin stopped suddenly my blog shown the following message:
    Fatal error: Call to undefined function get_option() in /home/anand/public_html/Wordpress/wp-admin/admin.php on line 32

    To further resolve the issue I manually removed wp-super cache plugin folder and also disabled all the active plugins through my-php-admin by resetting the value as a:0{}. Now the following error message is displayed

    Fatal error: Call to undefined function wp() in /home/anand/public_html/Wordpress/wp-blog-header.php on line 14

    I have tried to resolve the issue by upgrading/updating manually with a fresh wp installation leaving behind all necessary folders and files as written in manual update coding.
    However the message remains same. May I request you guys to help me in resolving this error message. My blog is down and it is like a nightmare. You may like to see the complete error message by clicking link of my blog that is http://earnwithanand.com/Wordpress

  2. ashodhiya
    Member
    Posted 3 years ago #

    Hi Christine, I have gone through all these three threads however my problem is not similar to those discussed there. Bottom-line, I have now already tried to do clean WP Installation, but to no avail.
    I have a complete backup of my whole site. Do you have any suggestions?
    You may like to see the complete error message by clicking my blog's link i.e. http://earnwithanand.com/Wordpress/
    Thanks for your kind, positive and swift response.
    Looking forward if there is solution to my problem.

  3. I just looked at your site and it seems to be working fine except on the pages.

    I don't see the Fatal error: Call to undefined function get_option() anywhere. I was able to go from your home page, to posts and archives no problem.

    The error on your page.php is a simple scripting error which should be easy to fix.

  4. ashodhiya
    Member
    Posted 3 years ago #

    Thanks Christine for your kind consideration and generosity.
    I tried to resolve the issue with all those suggestion you provided.
    And finally the blog was reinstated by fresh clean manua WP installations. The steps are as follows:-
    1. I renamed/deleted plugins folder.
    2. I renamed/deleted custimized theme folder to allow WP to fall on default theme.
    3. Did a clean install of WP manually.
    3. I copied wp.config file to my hard disk.
    4. I deleted the wp.config.file and presto!
    5. Login screen returned.
    6. Changed my wp-config file with the info I already had on my hard drive to get Network settings to work.
    7. Did changed my .htaccess file to get network to work.
    8. Re-logged in and found my all sites and content intact except plugins.
    9. Now I am installing plugins one by one while ensuring that my single.php is showing the content.
    That is it.
    On the fly, may I ask you whether there is any theme available which displays the content of a single post correctly as the WP Default theme (Kubric) does. Because default theme looks less attractive.
    Also I would like to mention here that as soon as I change the Permalink setting to /%id%/%postname%/, the blog does not show the content of single post however returns with a 404 error.
    And if I revert back to default permalink settings everything is fine.
    Any suggestions, please?

  5. With regards to the default theme, the new default theme is now TwentyTen. The Kubrick theme is really old and shouldn't be used anymore. I would encourage to give Twenty Ten a try and if you need to make changes to it, try creating a child theme.

    With regards tot he permalinks, it sounds like there's an issue with the server. Does your hosting provider have mod_rewrite enabled. Are you sure that the server is apache or linux? If you're on a windows box, you might be stuck with the default permalinks.

  6. ashodhiya
    Member
    Posted 3 years ago #

    Thanks Christine!

    Twenty Ten does not produce well formatted content (Justified) but left align which looks very ugly. Secondly, Twenty Ten only shows the summary of posts and not the full content of a post. Thirdly, it changes my Permalink from Default to customized one which render my Blog to show 404 error when single post is called for.

    My blog is on Hostgator and it has mod_rewrite enabled and the server is Linux based.

    Now I have come up with another problem also. Kindly have a look here I am getting some error on top of my blog.
    http://earnwithanand.com/Wordpress/

    Any suggestion to resolve please?

  7. karanlugani
    Member
    Posted 3 years ago #

    Finally solved this problem . Checkout How to Solve Fatal Errors of WordPress. Relax..!!

Topic Closed

This topic has been closed to new replies.

About this Topic