WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Fatal error: Call to undefined function w3tc_button_link() (33 posts)

  1. odyscope
    Member
    Posted 11 months ago #

    I attempt to install the plug-in but get the below error message:

    Fatal error: Call to undefined function w3tc_button_link() in /home/content/90/11587890/html/wp-content/plugins/w3-total-cache/lib/W3/GenericAdminEnvironment.php on line 99

    Any idea what's happening?

    http://wordpress.org/plugins/w3-total-cache/

  2. chocochrispi
    Member
    Posted 11 months ago #

    I'm having the same error on wordpress 3.6

  3. Vlad Dulea
    Member
    Posted 11 months ago #

    same problem here on a multi-site install (WP 3.6)

  4. Thomas van der Beek
    Member
    Posted 11 months ago #

    This worked for me: just remove the files/folders:

    - File: /wp-content/advanced-cache.php
    - Folder: /wp-content/cache/

    And try again. It will skip the missing function and install the correct files/folder for you.

  5. Vlad Dulea
    Member
    Posted 11 months ago #

    Thomas, tx
    it's true. deleting those files and folders solves the problem.
    thank you

  6. chocochrispi
    Member
    Posted 11 months ago #

    Thank you!

  7. mikewra
    Member
    Posted 11 months ago #

    Hi, Sorry this didn't work for me. I deleted /wp-content/advanced-cache.php but there was no folder /wp-content/cache/ to delete.
    I have also tried to uninstall and re-install, then when that failed I used ftp to delete the plug-in completely, then reinstalled and deleted advanced-cache.php and tried again. All produce the same fatal error. Any help is deeply appreciated.

  8. josua
    Member
    Posted 11 months ago #

    I'm also experiencing this, looking around for some times. I thought the file is in /wp-content/plugins/advanced-cache.php, silly. Also deleted /wp-content/cache/ and it works.

    Thanks for the solution.

  9. mikewra
    Member
    Posted 11 months ago #

    Ooops. Was going to the wrong wp-content.

    The correct location for those files is /public_html/blog/wp-content.

    I was going to /public_html/blog/wp-content/plugins/w3-total-cache/wp-content.

    Deletions on the upper level enabled installation of the add-on.

    Thanks

  10. mikewra
    Member
    Posted 11 months ago #

    Double oops. This plug-in just broke the entire site. I can't even get into admin now. Will have to do a complete restore from backup. Thanks, but no thanks to this addon.

    Warning: require_once(WP_PLUGIN_DIR/w3-total-cache/inc/functions/compat.php) [function.require-once]: failed to open stream: No such file or directory in /home/ripsyc5/public_html/blog/wp-content/plugins/w3-total-cache/inc/define.php on line 1449

    Fatal error: require_once() [function.require]: Failed opening required 'WP_PLUGIN_DIR/w3-total-cache/inc/functions/compat.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/ripsyc5/php') in /home/ripsyc5/public_html/blog/wp-content/plugins/w3-total-cache/inc/define.php on line 1449

  11. IagoMelanias
    Member
    Posted 10 months ago #

    Thanks Thomas.

  12. Jamil Ahmed
    Member
    Posted 10 months ago #

    This worked for me: just remove the files/folders:

    - File: /wp-content/advanced-cache.php
    - Folder: /wp-content/cache/

    And try again. It will skip the missing function and install the correct files/folder for you.

    its saved my time thanks

  13. rbmark
    Member
    Posted 10 months ago #

    I was directed here from a thread I started about this problem. None of the solutions listed here work.

    Any ideas?

  14. Hemant Aggarwal
    Member
    Posted 10 months ago #

    Having the same problem. Any sure shot solution?

  15. esmi
    Forum Moderator
    Posted 10 months ago #

    People, as per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  16. vjlamba
    Member
    Posted 10 months ago #

    i am also facing the same problem, i deleted the files and folders as stated above. Didnt work for me. Any other issues?

  17. fpats
    Member
    Posted 10 months ago #

    Great, followed the instructions after being pointed to this thread via another post on the forums and now my site is completely f*****

    Another great day for WordPress.

  18. pbure
    Member
    Posted 10 months ago #

    Deleting those two as per Thomas' instructions worked for me
    I suspect it maybe because I had Super Cache installed (default QuickInstall Hostgator setup), although it was not activated?

  19. Nicole18
    Member
    Posted 10 months ago #

    I deleted Super Cache and mine activated after just fine.

  20. The Max tech finder
    Member
    Posted 10 months ago #

    great thnx

  21. kevquirk
    Member
    Posted 10 months ago #

    This worked for me. Thanks.

  22. formerfatguy
    Member
    Posted 10 months ago #

    worked for me.

    thanks

  23. Ambhen
    Member
    Posted 10 months ago #

    It works for me now @Thomas.. Thank you! :)

  24. maxibaut
    Member
    Posted 10 months ago #

    thanks

  25. marty84
    Member
    Posted 9 months ago #

    This folder don't exist :/wp-content/cache/

  26. jampacked.kreativ
    Member
    Posted 9 months ago #

    rg1 wrkd 4 me.

  27. remas2010
    Member
    Posted 9 months ago #

    THANK U

  28. upadeshs
    Member
    Posted 9 months ago #

    thanks worked for me.

  29. wpgeekster
    Member
    Posted 8 months ago #

    Hey guys, this is a note to whoever reads this post in the future. If you want to delete a file or a folder, don't delete it. Rename it. Once you rename it, the plugin will no longer recognize it, so it will behave just like it was deleted, But you will then be able to rename it back to it's original name if it breaks your site.

    Hope that helps =)

  30. wpgeekster
    Member
    Posted 8 months ago #

    P.S You guys shouldn't remove files and folder if you don't know what it's doing. First of all if the folder is named chache, then that could indicate that is where w3 total cache stores all it's cached files. You could be entirely defeating the entire function of the plugin.

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags